Bug 1549097 - Even after removing service catalog, "Provisioned Services" in Applications sub-menu is not removed and gets stuck at "Loading...".
Summary: Even after removing service catalog, "Provisioned Services" in Applications s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.1
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.7.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 11:50 UTC by ggore
Modified: 2018-04-05 09:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when the service catalog was installed and then uninstalled using the Ansible playbooks, the web console still incorrectly shows the "Provisioned Services" menu item, which did not load any content when clicked. The bug has been fixed and the web console no longer shows the "Provisioned Services" menu after service catalog uninstall.
Clone Of:
Environment:
Last Closed: 2018-04-05 09:39:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0636 None None None 2018-04-05 09:40:24 UTC

Description ggore 2018-02-26 11:50:51 UTC
Description of problem:
Even after removing service catalog, "Provisioned Services" in Applications sub-menu is not removed and gets stuck at "Loading...". This is applicable for all projects including the new ones.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install OCP 3.7 with service catalog

2. Remove service catalog as below: 
# ansible-playbook -i hosts openshift-ansible/playbooks/byo/openshift-cluster/service-catalog.yml -e template_service_broker_remove=true -e template_service_broker_install=false -e ansible_service_broker_remove=true -e openshift_service_catalog_remove=true -e ansible_service_broker_install=false


Actual results:
"Provisioned Services" is not removed from Applications sub-menu in the web interface and it gets stuck at "Loading...".

Expected results:
"Provisioned Services" should be removed.

Comment 1 Samuel Padgett 2018-02-26 16:02:44 UTC
The underlying problem is that the web console checks whether the user has authority to list service instances to decide when to show the menu. Since that access is not removed from `edit` and `view` cluster roles on service catalog uninstall, the menu item is still visible. As a workaround, it's possible to edit the `edit` and `view` clusterroles to remove `list` from resource `servicecatalog.k8s.io/serviceinstances`.

We should fix the console to check that the resource exists and only add the menu when it does.

Comment 2 Samuel Padgett 2018-02-26 16:27:14 UTC
3.9 fix: https://github.com/openshift/origin-web-console/pull/2854

Comment 3 openshift-github-bot 2018-02-26 20:30:26 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/c5cca3d41e48360a5ffa92ae31a3eb2a4bfa43e8
Bug 1549097 - Update nav canI check

Check if the resource exists and if you have permission in navigation
canI checks. This avoids a problem where the resource has been removed,
but a role still grants access to the removed resource.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1549097

https://github.com/openshift/origin-web-console/commit/c2c57a691390f80d7c12bb7f055302db989b0a42
Merge pull request #2854 from spadgett/nav-api-info-check

Automatic merge from submit-queue.

Bug 1549097 - Update nav canI check

Check if the resource exists and if you have permission in navigation
canI checks. This avoids a problem where the resource has been removed,
but a role still grants access to the removed resource.

Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1549097

/assign @benjaminapetersen

Comment 4 Samuel Padgett 2018-02-26 21:11:32 UTC
3.7 fix: https://github.com/openshift/origin-web-console/pull/2855

Comment 5 Samuel Padgett 2018-02-27 13:39:49 UTC
3.8 fix: https://github.com/openshift/origin-web-console/pull/2856

Comment 7 Yadan Pei 2018-03-01 07:52:47 UTC
Checked fixes on v3.7.35 

1. Install OCP 3.7 with service catalog & TSB enabled
2. Provision some serviceinstances
3. Disable/Remove service catalog using ansible-playbook
4. Check "Provisioned Services" sub-menu on web console
"Provisioned Services" sub-menu is removed too

The issue is fixed on 3.7.z

Comment 8 Yadan Pei 2018-03-01 07:53:02 UTC
PR 2854 is not included in v3.9.1 yet, will check in newer 3.9 puddle

Comment 9 Yadan Pei 2018-03-05 07:26:24 UTC
Verified on v3.9.2 with same steps in comment 7, when service catalog is removed, "Provisioned Services" sub-menu is removed also.

Move to VERIFIED

Comment 13 errata-xmlrpc 2018-04-05 09:39:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0636


Note You need to log in before you can comment on or make changes to this bug.