Bug 154917 - Segmentation fault while compiling Xalan 1.9 sources
Segmentation fault while compiling Xalan 1.9 sources
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: gcc (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-14 16:30 EDT by Prasad Mysore
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasad Mysore 2005-04-14 16:30:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
I get this error below while trying compile xalan 1.9 sources that I downloaded from apache website.
....
g++ -O2 -DNDEBUG     -fno-elide-constructors -Wall -fPIC -DLINUX -D_REENTRANT -DXALAN_INMEM_MSG_LOADER -DXALAN_USE_ICU -c -I/home/essfs1/rmysore/xml-xalan/c/src -I/home/essfs1/rmysore/xml-xalan/c/include -I../../nls/include -I/home/essfs1/rmysore/xerces-c-src_2_6_0/src/ -I/home/essfs1/rmysore/xerces-c-src_2_6_0/include/xercesc -I/home/essfs1/rmysore/xerces-c-src_2_6_0/include/ -I/home/essfs1/rmysore/icu/include  -o ../../obj/XPathExecutionContextDefault.o /home/essfs1/rmysore/xml-xalan/c/src/xalanc/XPath/XPathExecutionContextDefault.cpp
/home/essfs1/rmysore/xml-xalan/c/src/xalanc/Include/XalanObjectCache.hpp: In method 
`xalanc_1_9::XPathExecutionContextDefault::XPathExecutionContextDefault (xalanc_1_9::XPathEnvSupport &, 
xalanc_1_9::DOMSupport &, xalanc_1_9::XObjectFactory &, xalanc_1_9::XalanNode *, const 
xalanc_1_9::NodeRefListBase *, const xalanc_1_9::PrefixResolver *)':
/home/essfs1/rmysore/xml-xalan/c/src/xalanc/Include/XalanObjectCache.hpp:291: Internal error: 
Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
gmake[1]: *** [../../obj/XPathExecutionContextDefault.o] Error 1
gmake[1]: Leaving directory `/home/essfs1/rmysore/xml-xalan/c/src/xalanc'
gmake: *** [all] Error 2


Version-Release number of selected component (if applicable):
gcc version 2.96 20000731

How reproducible:
Always

Steps to Reproduce:
1.
Download xerces 2.6 sources, icu 3.2 and xalan 1.9 Sources
2.
Setup the required environment variables etc as per xerces/icu build isntructions. 
Build Xerces and ICU first. No problem there. 
Then build xalan. 
3.
It is always the same file  xalanc/XPath/XPathExecutionContextDefault.cpp 

Actual Results:  Should compile.

Expected Results:  We use g++(gcc version 2.96 20000731). I searched through the bugs list and I found quite a few similar bugs with compiler.  None exactly to do with xalan sources.    I am wondering if this is because of any optimization settings.  I am not sure if there is a patch that already takes care of this problem or if there is a workaround.  

Additional info:
Comment 1 Max Polk 2006-03-07 17:40:47 EST
I found the same thing on RHEL, ES release 2.1, gcc 2.96, on Xalan 1.10 as well,
on the same line of code (line 293 in this Xalan version).

After -O2, use the "-fno-default-inline" option and compiler error goes away. 
Guess it had to do with optimization after all.
Comment 2 Prasad Mysore 2006-03-07 17:49:53 EST
This fixes the seg faults while building xalan.  On a side note, you might want 
to move to a different compiler version.  We ran into some issues/crashes at 
run time (with simple xalan transformation) using xalan built with gcc 2.96. 
Thats when I realized that gcc2.96 is not a very stable production release. So 
we moved to using gcc 3.2.3. That solved the problem. Take a look at this note 
from Dave Bertoni frm xalan dev. 
===================================================================
You should not be using this fake version of GCC for production work:

http://gcc.gnu.org/gcc-2.96.html

Since the code works on every other platform, including official 
released versions of GCC, I don't understand why you think this is a bug.  
The code is perfectly legal, and is likely failing because of a compiler 
or library bug.

Comment 3 RHEL Product and Program Management 2007-10-19 15:20:50 EDT
This bug is filed against RHEL2.1, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products.  Since
this bug does not meet that criteria, it is now being closed.

For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/

If you feel this bug is indeed mission critical, please contact your
support representative.  You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.