Bug 1549170 - overcloud deployment fails with "Host is not connected to any segments on routed provider network"
Summary: overcloud deployment fails with "Host is not connected to any segments on rou...
Keywords:
Status: CLOSED DUPLICATE of bug 1549536
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Harald Jensås
QA Contact: mlammon
URL:
Whiteboard:
: 1549057 1549367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 15:25 UTC by Bob Fournier
Modified: 2018-03-01 21:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-01 21:53:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1749671 None None None 2018-02-26 15:25:29 UTC
OpenStack gerrit 542215 'None' MERGED Make routed networks optional 2020-10-08 10:56:32 UTC

Description Bob Fournier 2018-02-26 15:25:29 UTC
An overcloud deployment fails due to the changes in Routed Network support in Queens. The error in ironic-conductor.log is:

Feb 20 16:25:33 undercloud75 ironic-conductor: 2018-02-20 16:25:33.252 7891 ERROR ironic.conductor.manager [req-955dcaa0-1183-4a7f-b9a9-98c946aa8e0f c7eefcdf202b4ee496915f4611bf335b 0cac09df2bc5475db6c3f4e1b8eb0a1c - default default] Error while preparing to deploy to node f0518679-17c5-4bf8-b5e1-890ee6418571: Unable to set binding:host_id for neutron port 151ecd10-6d48-4f81-8106-83866164844e. Error: Host f0518679-17c5-4bf8-b
9:50 5e1-890ee6418571 is not connected to any segments on routed provider network '676fe720-6277-484d-87e6-41a9b24ec057'.  It should be connected to one.
Description of problem:

Comment 1 Alexander Chuzhoy 2018-02-26 15:31:13 UTC
Reproduced.

Comment 2 Alexander Chuzhoy 2018-02-26 22:01:31 UTC
After applying the patch I was able to proceed further with the OC deployment.
All the nodes became active.

Comment 3 Harald Jensås 2018-02-27 13:16:50 UTC
*** Bug 1549057 has been marked as a duplicate of this bug. ***

Comment 4 Bob Fournier 2018-02-27 13:47:00 UTC
*** Bug 1549367 has been marked as a duplicate of this bug. ***

Comment 5 Bob Fournier 2018-03-01 21:53:12 UTC
Marking as duplicate of existing bug.

*** This bug has been marked as a duplicate of bug 1549536 ***


Note You need to log in before you can comment on or make changes to this bug.