Bug 1549220 - configmap still exist after running uninstall playbook for logging
Summary: configmap still exist after running uninstall playbook for logging
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.z
Assignee: Noriko Hosoi
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 18:13 UTC by Peter Ruan
Modified: 2018-06-06 15:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: logging-elasticsearch-ops was missing in the delete configmaps list in the openshift-ansible delete_logging role. Consequence: The logging-elasticsearch-ops configmap still exists after running uninstall ansible playbook for logging. Fix: Adding logging-elasticsearch-ops to the delete configmaps list. Result: All the logging configmaps including logging-elasticsearch-ops are uninstalled by running uninstall ansible playbook for logging.
Clone Of:
Environment:
Last Closed: 2018-06-06 15:46:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1796 0 None None None 2018-06-06 15:47:03 UTC

Description Peter Ruan 2018-02-26 18:13:27 UTC
Description of problem:
  After a installation of logging with pvc and ops 

Version-Release number of selected component (if applicable):
oc v3.9.0-0.51.0
openshift-ansible commit ID f8f01ef


How reproducible:
always

Steps to Reproduce:
1.Install logging with dynamic pv

[OSEv3:vars]
openshift_logging_install_logging=true
openshift_logging_use_ops=true
openshift_logging_es_pvc_dynamic=True
openshift_logging_es_cluster_size=1
openshift_logging_es_ops_pvc_dynamic=True
openshift_logging_es_ops_cluster_size=1
2. after installation.  Run uninstall with 
  openshift_logging_install_logging=false
3.

Actual results:
[root@host-172-16-120-58 ~]# oc get configmap
NAME                        DATA      AGE
logging-elasticsearch-ops   2         39m

Expected results:
configmap for logging service removed

Additional info:

Comment 1 Noriko Hosoi 2018-02-28 05:19:34 UTC
https://github.com/openshift/openshift-ansible/pull/7317

logging-elasticsearch-ops was missing in the delete configmaps task in openshift_logging/tasks/delete_logging.yaml.

Comment 2 Jeff Cantrill 2018-02-28 19:41:40 UTC
This will need a 3.9 backport since we now have a 3.9 branch.  Do we also need to backport to 3.7?

Comment 3 Noriko Hosoi 2018-02-28 19:50:29 UTC
(In reply to Jeff Cantrill from comment #2)
> This will need a 3.9 backport since we now have a 3.9 branch.  Do we also
> need to backport to 3.7?

I'd think so.  3.7 shares the same code with the newer versions.
"delete_logging.yaml"
# delete our configmaps
- name: delete configmaps
  oc_obj:
    state: absent
    kind: configmap
    namespace: "{{ openshift_logging_namespace }}"
    name: "{{ item }}"
  with_items:
    - logging-curator
    - logging-elasticsearch
    - logging-fluentd
    - logging-mux

Comment 4 openshift-github-bot 2018-03-09 22:10:17 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/08855ca23cb67d50c0db03beb3cf5713cdc4820e
Bug 1549220 - configmap still exist after running uninstall playbook for logging

Adding logging-elasticsearch-ops to delete configmaps item.

https://github.com/openshift/openshift-ansible/commit/141e68651e71ba38a9c0730137c50e49ff5e3fb4
Merge pull request #7317 from nhosoi/bz1549220

Bug 1549220 - configmap still exist after running uninstall playbook for logging

Comment 5 Jeff Cantrill 2018-03-16 19:56:04 UTC
3.9 cherrypick https://github.com/openshift/openshift-ansible/pull/7560

Comment 6 Noriko Hosoi 2018-04-24 19:23:35 UTC
(In reply to Jeff Cantrill from comment #5)
> 3.9 cherrypick https://github.com/openshift/openshift-ansible/pull/7560

Is it ok to remove /hold from the pr?

Comment 8 Anping Li 2018-05-30 03:24:05 UTC
The elasticsearch-ops configmap are can be removed by openshift-ansible-3.9.30-1.git.0.a91a657.el7.noarch

Comment 10 errata-xmlrpc 2018-06-06 15:46:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1796


Note You need to log in before you can comment on or make changes to this bug.