Bug 1549263 - Conflict when creating neutron port while deploying overcloud
Summary: Conflict when creating neutron port while deploying overcloud
Keywords:
Status: CLOSED DUPLICATE of bug 1549536
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 20:26 UTC by David Hill
Modified: 2018-03-01 19:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-01 19:34:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Undercloud heat/nova/ironic/etc logs (4.07 MB, application/x-gzip)
2018-02-27 22:02 UTC, David Hill
no flags Details

Description David Hill 2018-02-26 20:26:58 UTC
Description of problem:
Conflict when creating neutron port while deploying overcloud and the following logs are seen in /var/log/neutron/server.log:

2018-02-26 15:18:13.965 18633 DEBUG neutron.api.v2.base [req-0898d695-ced1-4aec-847d-3d95355e603e 5e9769944aed4e959fc13aebd9066124 5188470e0fdc4d9cafb5b8006fc0e5a7 - default default] Request body: {u'port': {u'binding:host_id': u'64febc80-46d6-4c9a-b3ef-94f1e2fefe90', u'binding:vnic_type': u'baremetal'}} prepare_request_body /usr/lib/python2.7/site-packages/neutron/api/v2/base.py:690
2018-02-26 15:18:14.281 18633 DEBUG neutron_lib.callbacks.manager [req-0898d695-ced1-4aec-847d-3d95355e603e 5e9769944aed4e959fc13aebd9066124 a5188470e0fdc4d9cafb5b8006fc0e5a7 - default default] Notify callbacks ['neutron.plugins.ml2.plugin.Ml2Plugin._ensure_default_security_group_handler-896539'] for port, before_update _notify_loop /usr/lib/python2.7/site-packages/neutron_lib/callbacks/manager.py:167
2018-02-26 15:18:14.836 18633 INFO neutron.pecan_wsgi.hooks.translation [req-0898d695-ced1-4aec-847d-3d95355e603e 5e9769944aed4e959fc13aebd9066124 5188470e0fdc4d9cafb5b8006fc0e5a7 - default default] PUT failed (client error): There was a conflict when trying to complete your request.
2018-02-26 15:18:14.837 18633 DEBUG neutron.pecan_wsgi.hooks.notifier [req-0898d695-ced1-4aec-847d-3d95355e603e 5e9769944aed4e959fc13aebd9066124 5188470e0fdc4d9cafb5b8006fc0e5a7 - default default] No notification will be sent due to unsuccessful status code: 409 after /usr/lib/python2.7/site-packages/neutron/pecan_wsgi/hooks/notifier.py:79
2018-02-26 15:18:14.839 18633 INFO neutron.wsgi [req-0898d695-ced1-4aec-847d-3d95355e603e 5e9769944aed4e959fc13aebd9066124 5188470e0fdc4d9cafb5b8006fc0e5a7 - default default] 192.0.2.1 "PUT /v2.0/ports/e57d9fc4-f5eb-4763-b90f-f65d7e7bd0ab HTTP/1.1" status: 409  len: 465 time: 1.2580612

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try deploying an overcloud using the latest puddles.
2.
3.

Actual results:
Fails to spawn overcloud nodes

Expected results:
Succeeds

Additional info:

Comment 1 David Hill 2018-02-26 20:31:37 UTC
(undercloud) [root@undercloud-0-rhosp13 ironic]# neutron port-list
neutron CLI is deprecated and will be removed in the future. Use openstack CLI instead.
+--------------------------------------+-------------------------------+----------------------------------+-------------------+----------------------------------------------------------------------------------------+
| id                                   | name                          | tenant_id                        | mac_address       | fixed_ips                                                                              |
+--------------------------------------+-------------------------------+----------------------------------+-------------------+----------------------------------------------------------------------------------------+
| 1cc7cd4b-a721-4ef3-83a2-4524adc4a359 | storage_management_virtual_ip | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:ff:20:54 | {"subnet_id": "0f7cb4a2-f1d2-474d-9b6e-112e3d4adf84", "ip_address": "172.19.0.19"}     |
| 3695c957-c8dd-42c4-840f-01408fe7cf68 | internal_api_virtual_ip       | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:8e:92:40 | {"subnet_id": "50837577-4fc2-4a01-bdcf-3411b4496999", "ip_address": "172.17.0.17"}     |
| 534d1cfa-98a6-4ebe-9692-2efbff450472 | public_virtual_ip             | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:cf:a2:99 | {"subnet_id": "a9061d2e-4c4f-4503-b704-3f99671e5776", "ip_address": "192.168.122.132"} |
| a9c297cd-b240-4a62-9977-e7c674915634 | storage_virtual_ip            | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:fd:5e:cb | {"subnet_id": "01bafffc-872a-4418-8c5d-744f9e28d674", "ip_address": "172.18.0.16"}     |
| ca4399f1-0a28-4a2d-835d-a5aad225ec2c | control_virtual_ip            | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:ac:48:48 |                                                                                        |
| d3eb1776-b279-4a20-b0ce-e8c3b2e094e8 | redis_virtual_ip              | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:c3:6a:84 | {"subnet_id": "50837577-4fc2-4a01-bdcf-3411b4496999", "ip_address": "172.17.0.19"}     |
| d55bdcab-8d22-4401-b850-fbd49a9aef41 |                               | e9dbe8f0d8c245a48ae21630ecf2a3b5 | fa:16:3e:de:18:a7 | {"subnet_id": "a1fe8412-a864-456e-b2bd-16803e8c3f20", "ip_address": "192.0.2.5"}       |
+--------------------------------------+-------------------------------+----------------------------------+-------------------+----------------------------------------------------------------------------------------+

Comment 2 David Hill 2018-02-26 20:32:15 UTC
(undercloud) [root@undercloud-0-rhosp13 ironic]# neutron router-list
neutron CLI is deprecated and will be removed in the future. Use openstack CLI instead.
The resource could not be found.
Neutron server returns request_ids: ['req-530eda11-31a9-4c7e-b9e3-a820aa5bc55b']

Comment 3 Alex Schultz 2018-02-27 18:00:46 UTC
Please provide logs form the undercloud and templates & deploy command being used.

Comment 4 David Hill 2018-02-27 22:02:44 UTC
Created attachment 1401562 [details]
Undercloud heat/nova/ironic/etc logs

Comment 5 David Hill 2018-02-27 22:04:52 UTC
Deployment command:

openstack overcloud deploy --templates /home/stack/rhosp13/my-overcloud -e /home/stack/rhosp13/my-overcloud/environments/network-isolation.yaml -e /home/stack/rhosp13/network-environment.yaml --control-scale 3 --compute-scale 1 --ceph-storage-scale 0 --control-flavor control --compute-flavor compute --ceph-storage-flavor ceph-storage --ntp-server 192.0.2.1 -e /home/stack/rhosp13/overcloud_images.yaml --libvirt-type kvm

Templates:
https://github.com/david-hill/rhosp13


The only difference I have in the templates is nic-configs ... I'm adding ExternalNetwork on nic2.

This works with RHOSP 12 and all previous releases.

Comment 6 Alex Schultz 2018-03-01 19:34:51 UTC
ironic/ironic-conductor.log:Neutron server returns request_ids: ['req-5c23a07e-fb5a-42d0-8734-9bc7e80be4b5']: Conflict: Host b5dc9820-8d57-45f7-8f78-c9025e03edba is not connected to any segments on routed provider network '2284c971-40f4-4999-90e4-a2b3ef617aac'.  It should be connected to one.

*** This bug has been marked as a duplicate of bug 1549536 ***


Note You need to log in before you can comment on or make changes to this bug.