Bug 1549482 - Quota: After deleting directory from mount point on which quota was configured, quota list command output is blank
Summary: Quota: After deleting directory from mount point on which quota was configur...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: quota
Version: 3.10
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: hari gowtham
QA Contact:
URL:
Whiteboard:
Depends On: 1418259
Blocks: 1418227
TreeView+ depends on / blocked
 
Reported: 2018-02-27 08:52 UTC by hari gowtham
Modified: 2018-03-10 12:37 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.10.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1418259
Environment:
Last Closed: 2018-03-10 12:37:56 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-02-27 08:56:34 UTC
REVIEW: https://review.gluster.org/19637 (Fixes quota list when stale gfid exist in quota.conf) posted (#1) for review on release-3.10 by hari gowtham

Comment 2 Worker Ant 2018-03-01 02:04:47 UTC
COMMIT: https://review.gluster.org/19637 committed in release-3.10 by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- Fixes quota list when stale gfid exist in quota.conf

when an rmdir is done, the gfid corresponding to the dir remains
in quota.conf (if a limit was configured on the dir). The quota
list should ignore them and print the remaining limits. In case
the last gfid in quota.conf happened to be stale, the print code
was getting skipped. Refactored the code to ensure printing happens.

>Change-Id: I3ac8e8a7a62d34e1fa8fd2734419459112c71797
>BUG: 1418259
>Signed-off-by: Sanoj Unnikrishnan <sunnikri@redhat.com>
>Reviewed-on: https://review.gluster.org/16507
>Smoke: Gluster Build System <jenkins@build.gluster.org>
>NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
>CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
>Reviewed-by: Manikandan Selvaganesh <manikandancs333@gmail.com>
>Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Change-Id: I3ac8e8a7a62d34e1fa8fd2734419459112c71797
BUG: 1549482
Signed-off-by: Hari Gowtham <hgowtham@redhat.com>

Comment 3 Shyamsundar 2018-03-10 12:37:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.11, please open a new bug report.

glusterfs-3.10.11 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000091.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.