Bug 1549505 - Backport patch to reduce duplicate code in server-rpc-fops.c
Summary: Backport patch to reduce duplicate code in server-rpc-fops.c
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: 3.12
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Mohit Agrawal
QA Contact:
URL:
Whiteboard:
Depends On: 1549501
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-27 09:49 UTC by Mohit Agrawal
Modified: 2018-04-06 11:06 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.12.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1549501
Environment:
Last Closed: 2018-04-06 11:06:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohit Agrawal 2018-02-27 09:49:24 UTC
+++ This bug was initially created as a clone of Bug #1549501 +++

Description of problem:
Backport upstream patch(https://review.gluster.org/#/c/18793/) to reduce 
duplicate code from server-rpc-fops.c

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Red Hat Bugzilla Rules Engine on 2018-02-27 04:46:47 EST ---

This bug is automatically being proposed for the release of Red Hat Gluster Storage 3 under active development and open for bug fixes, by setting the release flag 'rhgs‑3.4.0' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.

Comment 2 Worker Ant 2018-02-27 10:07:38 UTC
REVIEW: https://review.gluster.org/19638 (protocol/server: Backport patch to reduce duplicate code in server-rpc-fops.c) posted (#1) for review on release-3.12 by MOHIT AGRAWAL

Comment 3 Worker Ant 2018-03-02 04:11:37 UTC
COMMIT: https://review.gluster.org/19638 committed in release-3.12 by "MOHIT AGRAWAL" <moagrawa@redhat.com> with a commit message- protocol/server: Backport patch to reduce duplicate code in server-rpc-fops.c

> Signed-off-by: Amar Tumballi <amarts@redhat.com>
> (cherry picked from commit a81c0c2b9abdcb8ad73d0a226b53120d84082a09)

BUG: 1549505
Change-Id: Ifad0a88245fa6fdbf4c43d813b47c314d2c50435
Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>

Comment 4 Jiffin 2018-04-06 11:06:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.7, please open a new bug report.

glusterfs-3.12.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/maintainers/2018-March/004303.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.