This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 154967 - [x86_64] openoffice.org SEGV under strace
[x86_64] openoffice.org SEGV under strace
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 01:37 EDT by Leon Ho
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 05:48:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Leon Ho 2005-04-15 01:37:20 EDT
[root@dhcp-206 RPMS]# LANG=ja_JP.UTF-8 strace -f ooffice 2> test.log
[ Process PID=15391 runs in 32 bit mode. ]
Segmentation fault

[root@dhcp-206 RPMS]# rpm -q openoffice.org-core
openoffice.org-core-1.9.92-2

Additional Info:
Seems it is still running fine tho.
Comment 1 Caolan McNamara 2005-04-18 05:58:40 EDT
I don't really understand, OOo runs fine, but crashes when run under strace ?.

or always with or without strace something reports a segv but the main OOo gui
continues working, e.g. like a program spawned off by OOo ? Or it runs fine
unless the LANG is ja_JP ?
Comment 2 Leon Ho 2005-04-18 23:36:21 EDT
1. Yes Ooo run fines but crashes in strace
2. strace report segv, without strace it is fine. I think because I specify -f
to trace the child processes
3. it is non-locale specific. sorry for the confusion.
Comment 3 Caolan McNamara 2005-04-19 05:11:58 EDT
not currently reproducable under i386
Comment 4 Caolan McNamara 2005-04-28 09:11:20 EDT
I don't have a x86_64 box, can you verify if a) this is still the case, and if
so if b) it doesn't happen on stracing a random i386 binary under x86_64
Comment 5 Caolan McNamara 2005-05-04 05:48:43 EDT
you know, I really really doubt this is OOo specific, so I'm going to close it.
I'd suspect that it's something generic with 32bit apps on 64bit platform either
due to strace or due to some kernel issue.

Note You need to log in before you can comment on or make changes to this bug.