Bug 1549677 - [OSP13] Overcloud deployment failed on WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value
Summary: [OSP13] Overcloud deployment failed on WorkflowTasks_Step2_Execution: Invalid...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Thomas Hervé
QA Contact: Ronnie Rasouli
URL:
Whiteboard:
: 1549688 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-27 15:59 UTC by Omri Hochman
Modified: 2018-06-27 13:46 UTC (History)
12 users (show)

Fixed In Version: openstack-heat-10.0.0-0.20180223172410.43f122b.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:45:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1749645 None None None 2018-03-01 11:18:43 UTC
OpenStack gerrit 545371 'None' MERGED Pass mistral execution argument by name 2020-09-07 00:52:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:46:28 UTC

Description Omri Hochman 2018-02-27 15:59:54 UTC
[OSP13] Overcloud deployment failed on WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value


Environment: 
-------------
openstack-tripleo-heat-templates-8.0.0-0.20180215092255.el7ost.noarch
openstack-mistral-common-6.0.0-0.20180212131405.90d2a94.el7ost.noarch
openstack-mistral-engine-6.0.0-0.20180212131405.90d2a94.el7ost.noarch
puppet-mistral-12.2.1-0.20180213222103.88c904d.el7ost.noarch
python-mistral-6.0.0-0.20180212131405.90d2a94.el7ost.noarch
openstack-mistral-executor-6.0.0-0.20180212131405.90d2a94.el7ost.noarch
openstack-mistral-api-6.0.0-0.20180212131405.90d2a94.el7ost.noarch
python2-mistral-lib-0.4.0-0.20180211230142.d61073a.el7ost.noarch
python2-mistralclient-3.3.0-0.20180215125917.1008e4e.el7ost.noarch


Steps:
-------
Attempt to deploy overcloud using latest osp13 puddle 

Results:
---------
overcloud deployment fails. 


Failure Log:
------------
2018-02-21 19:51:24Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.1]: SIGNAL_IN_PROGRESS  Signal: deployment 754d8bd8-8766-453c-8ed3-4529b447534d succeeded
2018-02-21 19:51:25Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.1]: CREATE_COMPLETE  state changed
2018-02-21 19:51:30Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.0]: SIGNAL_IN_PROGRESS  Signal: deployment 50c6bfc1-8453-4a75-a477-cd27a9170fe6 succeeded
2018-02-21 19:51:31Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.0]: CREATE_COMPLETE  state changed
2018-02-21 19:51:37Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.2]: SIGNAL_IN_PROGRESS  Signal: deployment 7af29891-15f5-418b-b78d-24dc8561ba83 succeeded
2018-02-21 19:51:37Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1.2]: CREATE_COMPLETE  state changed
2018-02-21 19:51:38Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1]: CREATE_COMPLETE  Stack CREATE completed successfully
2018-02-21 19:51:38Z [overcloud.AllNodesDeploySteps.ControllerDeployment_Step1]: CREATE_COMPLETE  state changed
2018-02-21 19:51:39Z [overcloud.AllNodesDeploySteps.WorkflowTasks_Step2]: CREATE_IN_PROGRESS  state changed
2018-02-21 19:51:41Z [overcloud.AllNodesDeploySteps.WorkflowTasks_Step2]: CREATE_COMPLETE  state changed
2018-02-21 19:51:42Z [overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution]: CREATE_IN_PROGRESS  state changed
2018-02-21 19:51:43Z [overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution]: CREATE_FAILED  APIException: resources.WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value: '{'input': 'Heat managed', 'workflow_name': 'tripleo.overcloud.workflow_tasks.step2', 'params': '{"evaluate_env": false, "env": {"role_merged_configs":
2018-02-21 19:51:43Z [overcloud.AllNodesDeploySteps]: CREATE_FAILED  Resource CREATE failed: APIException: resources.WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value: '{'input': 'Heat managed', 'workflow_name': 'tripleo.overcloud.workflow_tasks.step2', 'params': '{"evaluate_env": false, "env":
2018-02-21 19:51:44Z [overcloud.AllNodesDeploySteps]: CREATE_FAILED  APIException: resources.AllNodesDeploySteps.resources.WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value: '{'input': 'Heat managed', 'workflow_name': 'tripleo.overcloud.workflow_tasks.step2', 'params': '{"evaluate_env": false, "
2018-02-21 19:51:44Z [overcloud]: CREATE_FAILED  Resource CREATE failed: APIException: resources.AllNodesDeploySteps.resources.WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value: '{'input': 'Heat managed', 'workflow_name': 'tripleo.overcloud.workflow_tasks.step2', 'params': '{

 Stack overcloud CREATE_FAILED

overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution:
  resource_type: OS::Mistral::ExternalResource
  physical_resource_id:
  status: CREATE_FAILED
  status_reason: |
    APIException: resources.WorkflowTasks_Step2_Execution: Invalid input for field/attribute wf_ex. Value: '{'input': 'Heat managed', 'workflow_name': 'tripleo.overcloud.workflow_tasks.step2', 'params': '{"evaluate_env": false, "env": {"role_merged_configs": {"ObjectStorage": {"swift::storage::all::incoming_chmod": "Du=rwx,g=rx,o=rx,Fu=rw,g=r,o=r", "swift::storage::all::account_server_workers": "auto", "tripleo::profile::base::sshd::options": {"Subsystem": "sftp  /usr/libexec/openssh/sftp-server", "UsePAM": "yes", "HostKey": ["/etc/ssh/ssh_host_rsa_key", "/etc/ssh/ssh_host_ecdsa_key", "/etc/ssh/ssh_host_ed25519_key"], "GSSAPICleanupCredentials": "no", "SyslogFacility": "AUTHPRIV", "GSSAPIAuthentication": "yes", "PasswordAuthentication": "no", "AuthorizedKeysFile": ".ssh/authorized_keys", "AcceptEnv": ["LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES", "LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT", "LC_IDENTIFICATION LC_ALL LANGUAGE", "XMODIFIERS"], "UsePrivilegeSeparation": "sandbox", "X11Forward

Comment 1 Omri Hochman 2018-02-27 16:00:56 UTC
seems same issue reported upstream for : 
https://bugs.launchpad.net/tripleo/+bug/1749645

Comment 2 Alexander Chuzhoy 2018-02-27 16:49:16 UTC
*** Bug 1549688 has been marked as a duplicate of this bug. ***

Comment 8 Omri Hochman 2018-04-04 02:14:10 UTC
unable to reproduce with openstack-heat-10.0.1-0.20180314232329.c2a66b1.el7ost.noarch

Comment 10 errata-xmlrpc 2018-06-27 13:45:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.