Bug 154975 - PnPACPI METHOD_NAME__CRS failure error message during boot
PnPACPI METHOD_NAME__CRS failure error message during boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 04:46 EDT by Albert Strasheim
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:38:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2005-04-15 04:46:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
I just upgraded to 2.6.11-1.14_FC3smp and I now receive the following error during bootup:

pnp: PnPACPI: METHOD_NAME__CRS failure for PNP0c01

I found this in /var/log/messages:

Apr 15 10:06:51 dogbert kernel: pnp: PnPACPI: METHOD_NAME__CRS failure for PNP0c01
Apr 15 10:06:51 dogbert kernel: pnp: PnP ACPI: found 9 devices
Apr 15 10:06:51 dogbert kernel: usbcore: registered new driver usbfs
Apr 15 10:06:51 dogbert kernel: usbcore: registered new driver hub
Apr 15 10:06:51 dogbert kernel: PCI: Using ACPI for IRQ routing
Apr 15 10:06:51 dogbert kernel: ** PCI interrupts are no longer routed automatically.  If this
Apr 15 10:06:51 dogbert kernel: ** causes a device to stop working, it is probably because the
Apr 15 10:06:51 dogbert kernel: ** driver failed to call pci_enable_device().  As a temporary
Apr 15 10:06:51 dogbert kernel: ** workaround, the "pci=routeirq" argument restores the old
Apr 15 10:06:51 dogbert kernel: ** behavior.  If this argument makes the device work again,
Apr 15 10:06:51 dogbert kernel: ** please email the output of "lspci" to bjorn.helgaas@hp.com
Apr 15 10:06:51 dogbert kernel: ** so I can fix the driver.
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution failed [\MCTH] (Node f7ffe540), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution failed [\OSFL] (Node f7ffe4c0), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node c19daf00), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-0158: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node c19daf00), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel: pnp: 00:08: ioport range 0x400-0x47f could not be reserved
Apr 15 10:06:51 dogbert kernel: pnp: 00:08: ioport range 0x680-0x6ff has been reserved
Apr 15 10:06:51 dogbert kernel: pnp: 00:08: ioport range 0x500-0x53f has been reserved

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.14_FC3smp

How reproducible:
Always

Steps to Reproduce:
1. Boot 2.6.11-1.14_FC3smp.
2. Check /var/log/messages
  

Actual Results:  PnPACPI error message

Expected Results:  No PNPACPI error message

Additional info:

I don't know if this is a serious problem.

Do you need any more information about my hardware or BIOS settings?
Comment 1 Albert Strasheim 2005-04-15 04:52:20 EDT
[root@dogbert ~]# cat /proc/cmdline 
ro root=LABEL=/ quiet pci=routeirq

Doesn't seem to fix the problem.

[root@dogbert ~]# /sbin/lspci 
00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface
(rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device
(rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI Controller
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI Controller
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI Controller
#4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller
(rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97
Audio Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
01:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 01)

More stuff from /var/log/messages:

Apr 15 10:06:51 dogbert kernel: pnp: PnP ACPI init
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\MCTH] (Node f7ffe540), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\OSFL] (Node f7ffe4c0), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\_SB_.PCI0.SBRG.PS2K._STA] (Node c19dcfc0), AE_AML_BUFFER_L
IMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-0158: *** Error: Method execution
failed [\_SB_.PCI0.SBRG.PS2K._STA] (Node c19dcfc0), AE_AML_BUFFER_L
IMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\MCTH] (Node f7ffe540), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\OSFL] (Node f7ffe4c0), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\_SB_.PCI0.SBRG.PS2M._STA] (Node c19dcf20), AE_AML_BUFFER_L
IMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-0158: *** Error: Method execution
failed [\_SB_.PCI0.SBRG.PS2M._STA] (Node c19dcf20), AE_AML_BUFFER_L
IMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\MCTH] (Node f7ffe540), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\OSFL] (Node f7ffe4c0), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-1138: *** Error: Method execution
failed [\_SB_.SYSM._CRS] (Node c19daf00), AE_AML_BUFFER_LIMIT
Apr 15 10:06:51 dogbert kernel:     ACPI-0158: *** Error: Method execution
failed [\_SB_.SYSM._CRS] (Node c19daf00), AE_AML_BUFFER_LIMIT
Comment 2 Jerry 2005-04-17 15:50:19 EDT
I am getting very similar messages.
Comment 3 Ian Shields 2005-05-24 22:14:46 EDT
I'm seeing similar on an Intel D845GEBV2 board. Problem does not occur at
2.6.10-1.770_FC3 but does occur with 2.6.11-1.14_FC3 and 2.6.11-1.27_FC3.
# dmesg | grep -i acpi
 BIOS-e820: 000000003ff40000 - 000000003ff50000 (ACPI data)
 BIOS-e820: 000000003ff50000 - 0000000040000000 (ACPI NVS)
ACPI: RSDP (v000 ACPIAM                                ) @ 0x000f7300
ACPI: RSDT (v001 INTEL  D845GBV2 0x20030714 MSFT 0x00000097) @ 0x3ff40000
ACPI: FADT (v002 INTEL  D845GBV2 0x20030714 MSFT 0x00000097) @ 0x3ff40200
ACPI: MADT (v001 INTEL  D845GBV2 0x20030714 MSFT 0x00000097) @ 0x3ff40300
ACPI: ASF! (v016 AMIASF I845GASF 0x00000001 MSFT 0x0100000d) @ 0x3ff44350
ACPI: DSDT (v001 INTEL  D845GBV2 0x0000010a MSFT 0x0100000d) @ 0x00000000
ACPI: PM-Timer IO Port: 0x408
ACPI: setting ELCR to 0200 (from 0e28)
ACPI: Subsystem revision 20050211
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs *3 4 5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
pnp: PnP ACPI init
    ACPI-1138: *** Error: Method execution failed [\MCTH] (Node f7ffee40),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\OSFL] (Node f7ffee60),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node
c18df800), AE_AML_BUFFER_LIMIT
    ACPI-0158: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node
c18df800), AE_AML_BUFFER_LIMIT
pnp: PnPACPI: METHOD_NAME__CRS failure for PNP0c01
pnp: PnP ACPI: found 12 devices
PCI: Using ACPI for IRQ routing
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:1d.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
ACPI: PCI interrupt 0000:00:1d.1[B] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 9
ACPI: PCI interrupt 0000:00:1d.2[C] -> GSI 9 (level, low) -> IRQ 9
ACPI: PCI Interrupt Link [LNKH] enabled at IRQ 10
ACPI: PCI interrupt 0000:00:1d.7[D] -> GSI 10 (level, low) -> IRQ 10
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 9 (level, low) -> IRQ 9
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 3
ACPI: PCI interrupt 0000:00:1f.3[B] -> GSI 3 (level, low) -> IRQ 3
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 3 (level, low) -> IRQ 3
ACPI: PCI interrupt 0000:01:00.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKE] enabled at IRQ 11
ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 11 (level, low) -> IRQ 11
    ACPI-1138: *** Error: Method execution failed [\MCTH] (Node f7ffee40),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\OSFL] (Node f7ffee60),
AE_AML_BUFFER_LIMIT
    ACPI-1138: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node
c18df800), AE_AML_BUFFER_LIMIT
    ACPI-0158: *** Error: Method execution failed [\_SB_.SYSM._CRS] (Node
c18df800), AE_AML_BUFFER_LIMIT
apm: overridden by ACPI.
ACPI: Processor [CPU1] (supports 8 throttling states)
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 9 (level, low) -> IRQ 9
ACPI wakeup devices:
ACPI: (supports S0 S1 S3 S4 S5)
ACPI: PCI interrupt 0000:02:08.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 3 (level, low) -> IRQ 3
ACPI: PCI interrupt 0000:00:1d.7[D] -> GSI 10 (level, low) -> IRQ 10
ACPI: PCI interrupt 0000:00:1d.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI interrupt 0000:00:1d.1[B] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI interrupt 0000:00:1d.2[C] -> GSI 9 (level, low) -> IRQ 9
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SLPB]
ibm_acpi: ec object not found
Comment 4 Robert Moore 2005-05-25 12:28:56 EDT
ACPI: Subsystem revision 20050211

This was fixed in version 20050310:

10 March 2005.  Summary of changes for version 20050310:

1) ACPI CA Core Subsystem:

The string-to-buffer implicit conversion code has been modified again after a 
change to the ACPI specification.  In order to match the behavior of the other 
major ACPI implementation, the target buffer is no longer truncated if the 
source string is smaller than an existing target buffer. This change requires 
an update to the ACPI spec, and should eliminate the recent 
AE_AML_BUFFER_LIMIT issues.

Comment 5 Dave Jones 2005-07-15 15:33:47 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Albert Strasheim 2005-07-17 14:16:27 EDT
Works for me with kernel-smp-2.6.11-1.1369_FC4.

Note You need to log in before you can comment on or make changes to this bug.