Bug 154984 - Sound Blaster Audigy 2 Value audio does not work
Sound Blaster Audigy 2 Value audio does not work
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
: FutureFeature
Depends On:
Blocks: 155240 181409
  Show dependency treegraph
Reported: 2005-04-15 08:05 EDT by Jussi Silvennoinen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHSA-2006-0575
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-08-10 17:03:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Adds support for SB Audigy 2 Value (13.87 KB, patch)
2005-04-15 08:07 EDT, Jussi Silvennoinen
no flags Details | Diff

  None (edit)
Description Jussi Silvennoinen 2005-04-15 08:05:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
SB Audigy 2 Value is not found by kudzu or system-config-soundcard.
Support was added in Alsa 1.08


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RHEL4 to a box with SB Audigy 2 Value
2. Run system-config-soundcard
3. No supported soundcards found

Actual Results:  No supported soundcards found.

Expected Results:  Supported soundcard found during bootup by kudzu and relevant configuration added.

Additional info:
Comment 1 Jussi Silvennoinen 2005-04-15 08:07:12 EDT
Created attachment 113219 [details]
Adds support for SB Audigy 2 Value

Adds support for SB Audigy 2 Value
Comment 4 Suzanne Hillman 2005-04-18 09:35:59 EDT
Internal RFE bug #155240 entered; will be considered for future releases.
Comment 5 John W. Linville 2005-11-08 16:10:48 EST
Test kernels w/ above patch available here: 
Please give them a try to verify that everything works, and post the 
Comment 6 Jussi Silvennoinen 2005-11-09 01:57:45 EST

I've been running various recompiled RHEL4 kernel's with the attached patch
since April without problems.
Comment 8 Jussi Silvennoinen 2006-03-13 05:23:13 EST
I guess it's not in U3?
Comment 9 John W. Linville 2006-03-13 11:46:11 EST
No, it missed the U3 cut-off back in November.  But, it should be in U4. 
Comment 11 Roderick Johnstone 2006-03-31 07:18:38 EST
I have one of these cards and have been unable to get it working with the
latest (as of yesterday) jwltest kernel 2.6.9-34.7.EL.jwltest.128smp on x86_64
in U2.

linux> lspci | grep Multi
03:09.0 Multimedia audio controller: Creative Labs SB0400 Audigy2 Value

The card seems to be detected fine (eg lots of relevant stuff in /proc/asound)
and the snd_emu10k1 module is loaded but there is no sound from the output.

I've been all through alsamixer and kmix and unmuted everything and turned every
volume up, but there is still no actual sound when issuing an aplay command. The
aplay command seems to somplete normally, not hanging or anything.

Is there anything apart from jwltest kernel thats needed to make this card work?
Comment 12 John W. Linville 2006-03-31 09:40:16 EST
AFAIK, nothing special is required to make it work.  Have you tried all the 
jacks (speaker, headphone, etc)?  Is there sound on any of them? 
Please attach the output of running "sysreport"...thanks! 
Comment 13 Roderick Johnstone 2006-04-04 11:00:47 EDT
I've tried all the outputs, no sound anywhere.

Can I email you the output rather than post to the list please?

By the way, this is actually on Scientific Linux rather than genuine Redhat
Comment 14 John W. Linville 2006-04-11 15:22:36 EDT
You can mark an attachment as private, if that is helpful.  If not, then email 
is fine with me.  But, I don't know if RH's mail server will accept anything 
that big... 
Comment 15 Jason Baron 2006-04-19 10:54:20 EDT
committed in stream U4 build 34.19. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/ However, there is a *serious* slab
corruption issue with this kernel, and thus it should not be released to
customers under any circumstances. I'll update this bug when the kernel is
stable again.
Comment 16 Jason Baron 2006-04-19 15:59:43 EDT
We've identified the corruption as specfic to x86-64 smp kernel builds 34.16 and
34.17. All other builds are safe for consumption.
Comment 19 Red Hat Bugzilla 2006-08-10 17:03:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.