Bug 1549840 - Pyrenamer fails to use eyed3
Summary: Pyrenamer fails to use eyed3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pyrenamer
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-27 21:16 UTC by Göran Uddeborg
Modified: 2018-03-11 22:18 UTC (History)
1 user (show)

Fixed In Version: pyrenamer-0.6.0-21.fc26 pyrenamer-0.6.0-21.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-11 19:59:12 UTC


Attachments (Terms of Use)

Description Göran Uddeborg 2018-02-27 21:16:17 UTC
Description of problem:
When starting pyrenamer, it warns on the console that music rename is disabled, and there indeed doesn't seem to be any such options in the GUI.  This is despite the python-eyed3 package being installed because of a package dependency.


Version-Release number of selected component (if applicable):
pyrenamer-0.6.0-18.fc27.noarch
python-eyed3-0.7.10-3.fc27.noarch


How reproducible:
Every time


Steps to Reproduce:
1. Run pyrenamer


Actual results:
WARNING: python-hachoir-metadata not found.
WARNING: python-eyed3 not found.
WARNING: Music rename disabled!
No music options in the GUI.


Expected results:
No warnings, at least not the last two.


Additional info:
Tracing pyrenamer, it tries to find a Python module under paths like "eyeD3".  However, the python files in the python-eyed3 are in a directory called "eyed3", with a lower case "d".  It appears to me there is a packaging incompatibility here, isn't it?

Comment 1 Gwyn Ciesla 2018-02-28 14:01:40 UTC
Looks like it. I'll patch, since upstream is dead.

Comment 2 Fedora Update System 2018-02-28 14:18:02 UTC
pyrenamer-0.6.0-21.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c9a574ea8c

Comment 3 Fedora Update System 2018-02-28 14:18:10 UTC
pyrenamer-0.6.0-21.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e3e38032c

Comment 4 Fedora Update System 2018-02-28 17:38:14 UTC
pyrenamer-0.6.0-21.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c9a574ea8c

Comment 5 Fedora Update System 2018-02-28 18:10:01 UTC
pyrenamer-0.6.0-21.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e3e38032c

Comment 6 Fedora Update System 2018-03-11 19:59:12 UTC
pyrenamer-0.6.0-21.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2018-03-11 22:18:39 UTC
pyrenamer-0.6.0-21.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.