Bug 1549861 (CVE-2017-18206) - CVE-2017-18206 zsh: buffer overrun in symlinks
Summary: CVE-2017-18206 zsh: buffer overrun in symlinks
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-18206
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=low,public=20170509,reported=2...
Depends On: 1567308 1567309
Blocks: 1549839
TreeView+ depends on / blocked
 
Reported: 2018-02-27 22:30 UTC by Laura Pardo
Modified: 2019-06-08 22:43 UTC (History)
7 users (show)

Fixed In Version: zsh 5.4
Doc Type: If docs needed, set a value
Doc Text:
A buffer overflow flaw was found in the zsh shell symbolic link resolver. A local, unprivileged user can create a specially crafted directory path which leads to a buffer overflow in the context of the user trying to do a symbolic link resolution in the aforementioned path. If the user affected is privileged, this leads to privilege escalation.
Clone Of:
Environment:
Last Closed: 2018-11-30 00:34:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:1932 None None None 2018-06-19 04:56:25 UTC
Red Hat Product Errata RHSA-2018:3073 None None None 2018-10-30 07:30:14 UTC

Description Laura Pardo 2018-02-27 22:30:29 UTC
A flaw was found in zsh prior 5.3.1. There was no check when copying to the internal xbuf2 for a preliminary test.


References:
https://sourceforge.net/p/zsh/code/ci/c7a9cf465dd620ef48d586026944d9bd7a0d5d6d

Comment 1 Jason Tibbitts 2018-02-27 22:39:45 UTC
The oldest non EOL branch of Fedora, F26, has zsh 5.3.1.  However, it does not appear to have this patch, so I believe that zsh 5.3.1 is also vulnerable to this.

The current F27 version (5.4.2) does have this code and should not be vulnerable.

Comment 2 Kamil Dudka 2018-03-06 14:06:30 UTC
(In reply to Laura Pardo from comment #0)
> A flaw was found in zsh prior 5.3.1.

The commit you refer to landed (192 commits) _after_ the 5.3.1 release.

Comment 3 Kamil Dudka 2018-03-06 15:47:04 UTC
fixed in zsh-5.3.1-7.fc26

Comment 8 errata-xmlrpc 2018-06-19 04:56:19 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6

Via RHSA-2018:1932 https://access.redhat.com/errata/RHSA-2018:1932

Comment 9 errata-xmlrpc 2018-10-30 07:30:05 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 7

Via RHSA-2018:3073 https://access.redhat.com/errata/RHSA-2018:3073


Note You need to log in before you can comment on or make changes to this bug.