Bug 1549931 - Trigger a deploy of DC manually caused too much time to finish because of evicted pods.
Summary: Trigger a deploy of DC manually caused too much time to finish because of evi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Tomáš Nožička
QA Contact: Wang Haoran
URL:
Whiteboard:
Depends On:
Blocks: 1590059
TreeView+ depends on / blocked
 
Reported: 2018-02-28 05:25 UTC by Wang Haoran
Modified: 2018-07-30 19:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some of the DC pods get evicted. Consequence: DC with recreate strategy waits for them until timeout is reached. Fix: DC no longer waits for evicted Pods as there is no reason to. Result: DC recreate strategy works fine even if evicted pods are present.
Clone Of:
: 1590059 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:10:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:10:30 UTC

Description Wang Haoran 2018-02-28 05:25:23 UTC
Description of problem:

Create a DeploymentConfig, after one pods evicted by the EvictionManager due to various node problem, will cause the next deploy cost too much time.
Version-Release number of selected component (if applicable):


How reproducible:

always
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Wang Haoran 2018-02-28 05:26:46 UTC
Per comment here:https://bugzilla.redhat.com/show_bug.cgi?id=1547169#c11

Comment 2 Tomáš Nožička 2018-03-20 13:22:21 UTC
master PR https://github.com/openshift/origin/pull/19029

3.9 will follow when that merges

Comment 3 Wang Haoran 2018-05-14 06:56:17 UTC
Verified with:
openshift v3.10.0-0.41.0
kubernetes v1.10.0+b81c8f8
etcd 3.2.16


steps:
1. Create an dc with Recreate Strategy
2. Create a large file on one of the node that running the workload, make the node underDiskPressure
3. trigger an deploy manually
4. check how long the new deploy will finished.

resutls: the new deploy finished very quickly.

Comment 5 Tomáš Nožička 2018-06-11 12:04:53 UTC
https://github.com/openshift/ose/pull/1307

Comment 8 errata-xmlrpc 2018-07-30 19:10:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.