Bug 1550138 - Warning shown in the GUI for deployments that take more than 5 minutes when it shouldn't
Summary: Warning shown in the GUI for deployments that take more than 5 minutes when i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.10.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-28 15:42 UTC by Alfredo Quiroga
Modified: 2018-07-30 19:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if a pod took more than 5 minutes to become ready, the web console would warn you, regardless of `timeoutSeconds` specified in the deployment configuration. For some applications, this period was too short. We've removed this warning from the web console. Since we now better highlight other problems on the overview, such as a crash-looping pods and image pull errors, the warning is less important.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:10:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:10:30 UTC

Description Alfredo Quiroga 2018-02-28 15:42:25 UTC
Description of problem:

When deploying an application that takes more than 5 minutes, even after we specify settings to include a delay of 15 minutes in the Deployment Configuration, the GUI (Web Console) still shows a warning telling the user that it is taking more than 5 minutes.

This should not be the case, if the user has already specified that the application will take more than 15 minutes, the GUI should not be showing warnings.

The culprit seems to be in the code found here:

https://github.com/openshift/origin/pull/4486/files#diff-9ebed9d7d8705c66721254370ba1345eR420

if (isContainerUnpreparedFilter(containerStatus)) {
+            warnings.push({reason: "Unprepared", message: "The container " + containerStatus.name + " has been running for more than five minutes and has not passed its readiness check."});
+          }

These values SHOULD NOT be hard-coded.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Samuel Padgett 2018-02-28 15:55:07 UTC
I don't disagree with your comment, but this is not a high severity bug. It's only meant to be a helpful warning and is working as intended. It's not an error and does not block anything from working.

Having said that, I agree we should change the behavior.

I'd like to consider removing the warning altogether. It was added during 3.0 development before we had container statuses. The console now shows when a container is crash-looping. The original problem we were trying to solve was that the pod appeared to be running in the UI, but the container itself hadn't started.

How are you specifying the 15 minute delay in the deployment config? Readiness probe? Deployment `timeoutSeconds`?

Comment 2 Alfredo Quiroga 2018-02-28 16:05:08 UTC
Thanks.

- A low priority is ok.
- Agree that it should be completely removed from the GUI.
- We are adding the readiness test as part of the Deployment Config object using timeoutSeconds.

Comment 4 openshift-github-bot 2018-03-06 16:16:23 UTC
Commits pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/3a85ae928be40f9799b63ca47c8446f516361835
Bug 1550138 - Remove 5 minute warning for pods

Remove the warning we show when a pod takes more than 5 minutes to
start. Some pods will take longer, particularly if they need to pull an
image. Since we now do a better job of surfacing container statuses when
a container is crash looping, the 5 minute warning is no longer needed
and sometimes misleading.

See discussion in https://bugzilla.redhat.com/show_bug.cgi?id=1550138

https://github.com/openshift/origin-web-console/commit/57086c97efd8e5983d250d3aef110f61e0a5eab0
Merge pull request #2869 from spadgett/remove-pod-stuck-warning

Automatic merge from submit-queue.

Bug 1550138 - Remove 5 minute warning for pods

Remove the warning we show when a pod takes more than 5 minutes to
start. Some pods will take longer, particularly if they need to pull an
image. Since we now do a better job of surfacing container statuses when
a container is crash looping, the 5 minute warning is no longer needed
and sometimes misleading.

See discussion in https://bugzilla.redhat.com/show_bug.cgi?id=1550138

/assign @benjaminapetersen

Comment 6 Yadan Pei 2018-05-17 07:27:39 UTC
Confirmed on v3.10.0-0.46.0, the warning message has been removed so the issues reported in this bug no longer exists.

Move to VERIFIED

Comment 8 errata-xmlrpc 2018-07-30 19:10:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.