Bug 155019 - acroread 7.0 displays blank when "swallow"ed
acroread 7.0 displays blank when "swallow"ed
Status: CLOSED DUPLICATE of bug 155020
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 14:27 EDT by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 17:33:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scott Tsai 2005-04-15 14:27:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Galeon/1.3.20

Description of problem:
ftp://ftp.adobe.com/pub/adobe/reader/unix/7x/7.0/enu/AdobeReader_enu-7.0.0-2.i386.rpm

The acrobat reader 7.0 i386.rpm released by Adobe contains the /usr/bin/acroread executable, but does not activate its own mozilla plugin by default. 

The shipped /etc/mozpluggerrc lists acroread ahead of xpdf and will execute it with the +useFrontEndProgram option for "don't open in existing instance" behavior, but the name of this option has been changed to -openInNewWindow in acoread 7.0, thus causing acroread to exit.

Version-Release number of selected component (if applicable):
mozplugger-1.6.2-1

How reproducible:
Always

Steps to Reproduce:
1. install Adobe acrobat reader 7.0 rpm
2. view URL pointing to PDF file
3. 
  

Actual Results:  mozilla shows a blank page

Expected Results:  Successful display of PDF file

Additional info:

I suggest trying acroread as a last resort for PDF in /etc/mozpluggerrc, favoring opensource viewers instead. If it is still desirable to support acoread in mozplugger then we should handle the version difference.
Comment 1 Scott Tsai 2005-04-15 17:33:35 EDT

*** This bug has been marked as a duplicate of 155020 ***

Note You need to log in before you can comment on or make changes to this bug.