Bug 155026 - SIGFPE with Winchester core Athlon 64/nForce3 running i386 FC3
Summary: SIGFPE with Winchester core Athlon 64/nForce3 running i386 FC3
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-04-15 19:15 UTC by Karen Spearel
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-13 18:38:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of failure (24.32 KB, text/plain)
2005-04-15 19:15 UTC, Karen Spearel
no flags Details

Description Karen Spearel 2005-04-15 19:15:41 UTC
Description of problem: Rhythmbox crashes when any mp3 is selected for playing
on system with Winchester Athlon64 on a Epox 9NDA3 (nForce 3 chipset -
snd-ice1712 alsa driver) motherboard.  The same files play fine over NFS on a
Athlon 64 Clawhammer core/Asus KV8 (snd-via82xx alsa sriver) motherboard running
the same version of Rhythmbox (0.8.8) under FC3 on the local network.  These
same files play with no trouble using XMMS on both systems under the same
conditions.  SIFFPE is generated after the song is selected (ie Rhythmbox comes
up and looks fine until a mp3 is selected for play).

Reporter is available for further testing of patches/fixes/attempts with
different compiler version as desired since this bug seems rather h/w specific
and may possibly show a problem with these very new CPUs.

Version-Release number of selected component (if applicable):
0.8.8 on updated FC3 i386 system (ie both systems running strictly 32 bit with
no 64 bit stuff installed)

How reproducible:
every time

Steps to Reproduce:
1. start Rhythmbox
2. select and dbl click mp3 file to play

  
Actual results:
"The Application 'rhythmbox' has quit unexpectedly"


Expected results:
ought to play the mp3

Additional info:

Attached is the tail end of an strace rhythmbox from a terminal.  Rhythmbox
comes up as expected and works normally until the file to play is dbl clicked. 
MP3 files are on an xfs filesystem...and as mentioned, are shipped over nfs to
the functioning system.  Importing from an EXT3 filesystem doesn't change the
failure.

Comment 1 Karen Spearel 2005-04-15 19:15:41 UTC
Created attachment 113249 [details]
strace of failure

Comment 2 Karen Spearel 2005-04-15 19:32:02 UTC
I perhaps could have been more clear about the CPU...it is the 939 pin version.

Comment 3 Karen Spearel 2005-04-22 16:33:10 UTC
Not much interest here, I guess...The reason for posting originally was the
thought that perhaps SSE3 instructions that are listed on the AMD specs for 90nm
cores are causing the problem...if so, this will soon be a problem with all new
Athlon 64s including the duallys.  Since the AMD site shows SSE3 for both 754
and 939, this will eventually include Semprons too.  Anyhow, totem and xmms work
on the same mp3s that give the SIGFPE in rhythmbox

Comment 4 Karen Spearel 2005-05-12 20:42:41 UTC
problem doesn't exist with Ubuntu 5.04 x86_64/rhythmbox 0.8.8.  Can't seem to
find mp3 stuff to try with FC4T3 x86_64.

Comment 5 Karen Spearel 2005-05-14 03:33:34 UTC
ok, I guess this can be marked as notabug...must be a misconfiguration elewhere
in my FC3 setup because it doesn't happen using Rhythmbox 0.8.8 with either
Ubuntu i386 or AMD64 on the system that was throwing the SIGFPE.

Comment 6 Karen Spearel 2005-06-09 07:03:45 UTC
all is working on FC4T3 x86_64 with a new set of gstreamer-plugins  This can be
closed

Comment 7 Colin Walters 2005-06-13 18:38:18 UTC
Ok, closing, thanks.


Note You need to log in before you can comment on or make changes to this bug.