Bug 1550534 - systemd doesn't delete stub unit files created for session scopes
Summary: systemd doesn't delete stub unit files created for session scopes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.4
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks: 1709187 1711876
TreeView+ depends on / blocked
 
Reported: 2018-03-01 12:16 UTC by Michal Sekletar
Modified: 2019-05-20 09:48 UTC (History)
8 users (show)

Fixed In Version: systemd-219-58.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1709187 1711876 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:32:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3245 None None None 2018-10-30 11:33:10 UTC
Red Hat Bugzilla 1439989 'high' 'CLOSED' 'why so many sessions scope file didn''t been deleted?' 2019-12-02 20:31:56 UTC
Red Hat Knowledge Base (Solution) 3456751 None None None 2018-05-23 08:59:33 UTC

Internal Links: 1439989

Description Michal Sekletar 2018-03-01 12:16:31 UTC
Description of problem:
Every PAM session has scope unit associated with it. In the session creation process, we also create stub unit file for the given scope unit alongside drop-in configuration for it. However, when the session ends we don't delete this stub unit file.

Version-Release number of selected component (if applicable):
systemd-219-42.el7_4.7

How reproducible:
always

Steps to Reproduce:
1. ssh into the machine
2. cat /run/systemd/system/session-${XDG_SESSION_ID}.scope
3. log out
4. ssh back again
5. env | grep XDG_SESSION_ID (session ID should be different)
6. verify that old session scope unit file is still present

Actual results:
Old session-${XDG_SESSION_ID}.scope unit file present in /run/systemd/system

Expected results:
Unit file is deleted when session ends

Additional info:
https://github.com/lnykryn/systemd-rhel/pull/186

Comment 3 Frantisek Sumsal 2018-05-28 09:47:53 UTC
qa_ack+ for RHEL 7.6

Comment 4 Lukáš Nykrýn 2018-06-19 13:01:23 UTC
fix merged to staging branch -> https://github.com/lnykryn/systemd-rhel/pull/186 -> post

Comment 8 errata-xmlrpc 2018-10-30 11:32:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3245


Note You need to log in before you can comment on or make changes to this bug.