Bug 1550634 - Drop 3.6 and 4.0 datacenter/cluster level
Summary: Drop 3.6 and 4.0 datacenter/cluster level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ovirt-4.3.0
: ---
Assignee: Martin Perina
QA Contact: meital avital
URL:
Whiteboard:
: 1455525 (view as bug list)
Depends On:
Blocks: 1455534
TreeView+ depends on / blocked
 
Reported: 2018-03-01 16:39 UTC by Michal Skrivanek
Modified: 2020-05-28 11:50 UTC (History)
14 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: Release Note
Doc Text:
This release removes the Red Hat Virtualization Manager support for clusters levels 3.6 and 4.0. Customers must upgrade their data centers to Red Hat Virtualization Manager 4.1 or later before upgrading to Red Hat Virtualization Manager 4.3.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:37:22 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1655115 0 high CLOSED Drop 3.6 and 4.0 datacenter/cluster level 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2019:1085 0 None None None 2019-05-08 12:37:42 UTC
oVirt gerrit 95167 0 'None' ABANDONED engine: Remove Cluster Levels 3.6, 4.0 and 4.1 2020-11-25 07:23:09 UTC
oVirt gerrit 95190 0 'None' MERGED engine: Remove Cluster Levels 3.6 and 4.0 2020-11-25 07:23:08 UTC
oVirt gerrit 95270 0 'None' MERGED revert: engine: Remove Cluster Levels 3.6 and 4.0 2020-11-25 07:23:33 UTC
oVirt gerrit 95467 0 'None' MERGED core: Use latest cluster level in fencing tests 2020-11-25 07:23:33 UTC
oVirt gerrit 95468 0 'None' MERGED core: Remove older versions from VersionTest 2020-11-25 07:23:33 UTC
oVirt gerrit 95469 0 'None' MERGED core: Remove 3.6 from FenceProxyLocatorTest 2020-11-25 07:23:09 UTC
oVirt gerrit 95470 0 'None' MERGED core: Remove usage of older versions in GlusterTasksSyncJobTest 2020-11-25 07:23:10 UTC
oVirt gerrit 95471 0 'None' MERGED core: Replace 3.6 version with 4.3 in StorageDeviceSyncJobTest 2020-11-25 07:23:09 UTC
oVirt gerrit 95472 0 'None' MERGED core: Replace 3.6 version with 4.3 in CreateGlusterVolumeGeoRepSessionCommandTest 2020-11-25 07:23:10 UTC
oVirt gerrit 95473 0 'None' MERGED core: Replace 3.6 version with 4.3 in LabelDaoTest 2020-11-25 07:23:11 UTC
oVirt gerrit 95474 0 'None' MERGED core: Replace version 3.6 with 4.3 in RefreshLunsSizeCommandTest 2020-11-25 07:23:34 UTC
oVirt gerrit 95475 0 'None' MERGED core: Remove usage of older versions in OsRepositoryImplTest 2020-11-25 07:23:11 UTC
oVirt gerrit 95476 0 'None' MERGED core: Replace usage of older versions in UpdateVmCommandTest 2020-11-25 07:23:10 UTC
oVirt gerrit 95477 0 'None' MERGED core: Remove usage of older versions in RunVmValidatorTest 2020-11-25 07:23:10 UTC
oVirt gerrit 95478 0 'None' MERGED core: Set always firewalld as default firewall type 2020-11-25 07:23:12 UTC
oVirt gerrit 95479 0 'None' MERGED core: Remove test for SRIOV hot plug support in VmValidator 2020-11-25 07:23:35 UTC
oVirt gerrit 95480 0 'None' MERGED core: Remove LegacyVideoSettings 2020-11-25 07:23:12 UTC
oVirt gerrit 95481 0 'None' MERGED frontend: Replace 3.6 version with 4.0 in SnapshotModel 2020-11-25 07:23:12 UTC
oVirt gerrit 95482 0 'None' MERGED frontend: Replace 3.6 with latest version in tests inherited from BaseVmTest 2020-11-25 07:23:12 UTC
oVirt gerrit 95483 0 'None' MERGED core: Remove usage of older versions in NetworkConfiguratorTest 2020-11-25 07:23:12 UTC
oVirt gerrit 95484 0 'None' MERGED core: Replace usage of older versions in OvfManagerTest 2020-11-25 07:23:12 UTC
oVirt gerrit 95485 0 'None' MERGED core: Replace 3.6 version with 4.3 in ClusterFeatureDaoTest 2020-11-25 07:23:13 UTC
oVirt gerrit 95486 0 'None' MERGED core: Remove reference to version 3.6 in VdsOptionDaoTest 2020-11-25 07:23:13 UTC
oVirt gerrit 95487 0 'None' MERGED core: Remove DC/cluster version 3.6 2020-11-25 07:23:13 UTC
oVirt gerrit 95625 0 'None' MERGED core: Remove AdPartnerMacSupported option 2020-11-25 07:23:13 UTC
oVirt gerrit 95626 0 'None' MERGED core: Remove GlusterSelfHealMonitoringSupported option 2020-11-25 07:23:13 UTC
oVirt gerrit 95627 0 'None' MERGED core: Remove LegacyGraphicsDisplay option 2020-11-25 07:23:37 UTC
oVirt gerrit 95628 0 'None' MERGED core: Remove option MigrationPoliciesSupported 2020-11-25 07:23:14 UTC
oVirt gerrit 95629 0 'None' MERGED core: Remove OvsSupported option 2020-11-25 07:23:13 UTC
oVirt gerrit 95630 0 'None' MERGED core: Remove options SriovHotPlugSupported 2020-11-25 07:23:14 UTC
oVirt gerrit 95631 0 'None' MERGED core: Remove BackupSupported option 2020-11-25 07:23:13 UTC
oVirt gerrit 95927 0 'None' MERGED core: Remove GlusterServiceEnabled option 2020-11-25 07:23:14 UTC
oVirt gerrit 96117 0 'None' ABANDONED core: Remove all versions older than 4.0 from fixtures.xml 2020-11-25 07:23:14 UTC
oVirt gerrit 96295 0 'None' MERGED core: Replace 4.0 with newer versions in VmValidatorTest 2020-11-25 07:23:14 UTC
oVirt gerrit 96296 0 'None' MERGED core: Replace 4.1 with latest version in gluster tests 2020-11-25 07:23:14 UTC
oVirt gerrit 96297 0 'None' MERGED core: Replace 4.0 with latest version in DevicePropertiesUtilsTest 2020-11-25 07:23:14 UTC
oVirt gerrit 96298 0 'None' MERGED core: Use newer versions in CreateGlusterVolumeCommandTest 2020-11-25 07:23:14 UTC
oVirt gerrit 96299 0 'None' MERGED core: Use newer versions in GetDeviceListVDSCommandTest 2020-11-25 07:23:14 UTC
oVirt gerrit 96300 0 'None' MERGED core: Use newer versions in UpdateVmDiskCommandTest 2020-11-25 07:23:14 UTC
oVirt gerrit 96301 0 'None' MERGED core: Use newer versions in StorageDomainValidatorTest 2020-11-25 07:23:15 UTC
oVirt gerrit 96302 0 'None' MERGED core: Use newer version in AddVm* tests 2020-11-25 07:23:15 UTC
oVirt gerrit 96303 0 'None' MERGED core: Replace 4.0 with 4.2 in EmulatedMachineUtilsTest 2020-11-25 07:23:15 UTC
oVirt gerrit 96304 0 'None' MERGED core: Use newer versions in OsRepositoryImplTest 2020-11-25 07:23:15 UTC
oVirt gerrit 96305 0 'None' MERGED core: Use newer versions in NetworkConfiguratorTest 2020-11-25 07:23:15 UTC
oVirt gerrit 96306 0 'None' MERGED core: Stop sending disconnect action in SetVmTicketVDSCommand 2020-11-25 07:23:15 UTC
oVirt gerrit 96307 0 'None' MERGED frontend: Remove warning about HE unavailable version < 4.0 2020-11-25 07:23:16 UTC
oVirt gerrit 96308 0 'None' MERGED core: Stop removing Cirrus devices during import 2020-11-25 07:23:16 UTC
oVirt gerrit 96309 0 'None' MERGED core: Replace 4.0 with 4.1 in SnapshotModel 2020-11-25 07:23:16 UTC
oVirt gerrit 96310 0 'None' MERGED core: Replace 4.0 with 4.1 in ChangeDiskCommand 2020-11-25 07:23:16 UTC
oVirt gerrit 96311 0 'None' MERGED core: Remove 4.0 DC/cluster support 2020-11-25 07:23:16 UTC
oVirt gerrit 96332 0 'None' MERGED core: Use newer versions in NetworkFilterDaoTest 2020-11-25 07:23:16 UTC
oVirt gerrit 96385 0 'None' MERGED core: Remove DataOperationsByHSM option 2020-11-25 07:23:16 UTC
oVirt gerrit 96386 0 'None' MERGED core: Remove DiscardAfterDeleteSupported option 2020-11-25 07:23:16 UTC
oVirt gerrit 96387 0 'None' MERGED core: Remove GetNamesOfVmsFromExternalProviderSupported option 2020-11-25 07:23:17 UTC
oVirt gerrit 96390 0 'None' MERGED core: Remove option GlusterSupportArbiterVolume 2020-11-25 07:23:17 UTC
oVirt gerrit 96391 0 'None' MERGED core: Remove option Ipv6Supported 2020-11-25 07:23:17 UTC
oVirt gerrit 96392 0 'None' ABANDONED core: Remove option ManagedBlockDomainSupported 2020-11-25 07:23:18 UTC
oVirt gerrit 96393 0 'None' MERGED core: Remove option QcowCompatSupported 2020-11-25 07:23:18 UTC
oVirt gerrit 96394 0 'None' ABANDONED core: Remove option QemuimgCommitSupported 2020-11-25 07:23:18 UTC
oVirt gerrit 96395 0 'None' MERGED core: Remove option ReduceDeviceFromStorageDomain 2020-11-25 07:23:18 UTC
oVirt gerrit 96396 0 'None' MERGED core: Remove option VirtIOScsiIOThread 2020-11-25 07:23:18 UTC
oVirt gerrit 96397 0 'None' MERGED core: Remove option VmLeasesSupported 2020-11-25 07:23:18 UTC
oVirt gerrit 96411 0 'None' MERGED core: Remove option PassDiscardSupported 2020-11-25 07:23:19 UTC

Internal Links: 1655115

Description Michal Skrivanek 2018-03-01 16:39:14 UTC
We have a lot of legacy code supporting 3.6-4.1 compatibility in ovirt-engine and vdsm. Let's eliminate that significant amount of legacy code

Comment 10 Steven Rosenberg 2018-10-31 16:38:51 UTC
Only Versions 3.6 and 4.0 are to be deprecated. The documentation should be updated accordingly.

Comment 11 Ryan Barry 2018-10-31 20:49:38 UTC
Note: the deprecation is UX only. The backing code paths in VDSM/engine will not be removed (nacked), so we're pretty much just hiding vdc_options, which users can still set from engine-config if they need them.

Comment 16 Pedut 2019-01-30 07:17:38 UTC
Verified on 4.3.0-0.8.rc2.el7.
The following test scenarios were tested:
1. In engine creating data centers and clusters with versions 3.6 or 4.0 (both UI and RESTAPI) failed with error selected compatibility version is not supported as it should.
2. Upgrading engine from 4.2 to 4.3
    a. When 4.2 setup contains at least 1 data center or cluster with version 3.6 or 4.0, then upgrade to 4.3 failed as it should
    b. When 4.2 setup contains only data centers or clusters with version 4.1 and higher then the upgrade continue as it should

Comment 17 Andrea Perotti 2019-02-05 11:55:30 UTC
Hi, what is the expected behaviour in case of VMs with pending changes originated by a previous cluster compatibility change?

scenario:

a) a VM was created on cluster at compatibility level 4.0 
b) cluster compatibility has been increased to level 4.1 or maybe even to 4.2
c) VM for business reasons has not yet being stopped to apply the pending changes, so technically they are still in 4.0 mode

Will RHV be able to correctly handle those?
Will the update be denied to environments with VM with pending changes or should be the CU to ensure that no VM has pending changes before upgrading?


thanks

Comment 18 Martin Perina 2019-02-05 12:58:18 UTC
(In reply to Andrea Perotti from comment #17)
> Hi, what is the expected behaviour in case of VMs with pending changes
> originated by a previous cluster compatibility change?
> 
> scenario:
> 
> a) a VM was created on cluster at compatibility level 4.0 
> b) cluster compatibility has been increased to level 4.1 or maybe even to 4.2
> c) VM for business reasons has not yet being stopped to apply the pending
> changes, so technically they are still in 4.0 mode
> 
> Will RHV be able to correctly handle those?

At the moment we are just blocking upgrade to 4.3 if there is existing data center or cluster with 3.6/4.0 compatibility level, but we don't check VM level

> Will the update be denied to environments with VM with pending changes or
> should be the CU to ensure that no VM has pending changes before upgrading?

Ryan, this is out of my knowledge, could you please aswer above?

Comment 21 errata-xmlrpc 2019-05-08 12:37:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085

Comment 22 Martin Perina 2019-08-21 06:35:54 UTC
*** Bug 1455525 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.