Bug 1550679 - Scrolling operations cause X session to crash with XFCE and Mate
Summary: Scrolling operations cause X session to crash with XFCE and Mate
Keywords:
Status: CLOSED DUPLICATE of bug 1547612
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-01 19:00 UTC by Clark Williams
Modified: 2018-03-01 19:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-01 19:26:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Clark Williams 2018-03-01 19:00:27 UTC
Environment:

    Fedora 27 (up to date)
    Lenovo T460p laptop, 32GB RAM
    various kernels (currently 4.14.22-300)
    XFCE Desktop with lightdm as display manager

Description of problem:

Bringing up emacs and doing any scrolling operations (not paging but line scrolling) causes the X session to crash. 

Journalctl log seems to indicate that an i915 graphics hang may be part of the problem:

[drm] GPU HANG: ecode 9:0:0x85dffffb, in Xorg [1834], reason: Hang on rcs0, action: reset
i915 0000:00:02.0: Resetting rcs0 after gpu hang
i915 0000:00:02.0: Resetting rcs0 after gpu hang
DHCPREQUEST on wlp3s0 to 10.192.206.245 port 67 (xid=0x5a386f31)
i915 0000:00:02.0: Resetting rcs0 after gpu hang
DHCPREQUEST on wlp3s0 to 10.192.206.245 port 67 (xid=0x5a386f31)
i915 0000:00:02.0: Resetting rcs0 after gpu hang
i915 0000:00:02.0: Resetting rcs0 after gpu hang
XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
      after 60106 requests (60106 known processed) with 0 events remaining.
ANOM_ABEND auid=5159 uid=5159 gid=5160 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=31202 comm="emacs" e
ANOM_ABEND auid=5159 uid=5159 gid=5160 ses=2 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=23178 comm="emacs" e
Endpoint unregistered: sender=:1.48 path=/MediaEndpoint/A2DPSource
xfce4-notifyd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.


Shortly after this emacs dumps core and current session dies, resulting in a login prompt. 

I have not tried with Gnome3, but will try to reproduce there as well.

Comment 1 Clark Williams 2018-03-01 19:26:59 UTC
Wups, just spotted https://bugzilla.redhat.com/show_bug.cgi?id=1547612 which looks to be the same bug. Closing mine as a duplicate

*** This bug has been marked as a duplicate of bug 1547612 ***


Note You need to log in before you can comment on or make changes to this bug.