Bug 1550720 - Can't specifically modify haproxy timeouts per service
Summary: Can't specifically modify haproxy timeouts per service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: Udi Shkalim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-01 21:23 UTC by rosingh
Modified: 2019-12-29 10:33 UTC (History)
13 users (show)

Fixed In Version: puppet-tripleo-8.3.2-0.20180327181745.40b702f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:46:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1755711 None None None 2018-03-14 10:19:01 UTC
OpenStack gerrit 554153 None stable/queens: MERGED puppet-tripleo: Allow custom per-service listen_options for haproxy (Icb7f026190b310d34c47dc059e2fdb22031b0963) 2018-03-29 16:03:28 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:48:04 UTC

Description rosingh 2018-03-01 21:23:38 UTC
Description of problem:
Not able to change client/server time-out for cinder/nova/keystone alone.

Version-Release number of selected component (if applicable): OSP 12


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 rosingh 2018-03-01 21:30:45 UTC
we'd like a way to configure haproxy timeouts per service, like in:
$mysql_listen_options = {
'option'         => [ 'tcpka', 'httpchk' ],
'timeout client' => '90m',
'timeout server' => '90m',
'stick-table'    => 'type ip size 1000',
'stick'          => 'on dst',
'maxconn'        => $mysql_max_conn
 }

Comment 8 Michele Baldessari 2018-03-24 07:16:15 UTC
Queens backport merged, moving to POST

Comment 12 errata-xmlrpc 2018-06-27 13:46:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.