Bug 15508 - RFE: rpm CLI needs a dependency solver
RFE: rpm CLI needs a dependency solver
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-05 14:43 EDT by Pekka Savola
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-30 14:23:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2000-08-05 14:43:32 EDT
This happens with both RPM 3.0.5 and RPM 4.0.0-0.59.

rpm -F doesn't add packages that are Required: among the upgrade/install
list.

An example:

samba-2.0.3-8 installed.

Running 'rpm -F *.rpm' in directory containing:
---
-rw-rw-r--    1 pekkas   pekkas    1744775 Sep 27  1999
samba-2.0.5a-12.i386.rpm
-rw-rw-r--    1 pekkas   pekkas     434243 Sep 27  1999
samba-client-2.0.5a-12.i386.rpm
-rw-rw-r--    1 pekkas   pekkas     343001 Sep 27  1999
samba-common-2.0.5a-12.i386.rpm
---

Causes the message:
---
error: failed dependencies:
        samba-common = 2.0.5a is needed by samba-2.0.5a-12
---

Apparently RPM does not examine 'Provides:', 'Requires:' etc. headers
at all (or not soon enough) and dependecies fail because RPM won't install
samba-common.

This is an essential feature and should definitely be included.
Comment 1 Jeff Johnson 2000-08-06 17:15:08 EDT
FWIW, "rpm -F ..." has never added other packages, so this is a RFE.
Comment 2 Pekka Savola 2000-08-06 17:25:46 EDT
True, thus 'enhancement'. :)

Comment 3 Jeff Johnson 2001-01-09 11:54:22 EST
Getting closer to a chance to implement, but up2date is the cat's pajamas at the
moment (sigh)
Comment 4 Aleksey Nogin 2001-08-16 16:45:38 EDT
up2date does not completely solve this problem - what if I want to upgrade from
some custom list of packages (and some of them may be local or 3rd party)?
Comment 5 Jeff Johnson 2002-04-13 18:48:24 EDT
bash$ sudo rpm -Uvh curl-devel-7.9.5-2.i386.rpm 
warning: curl-devel-7.9.5-2.i386.rpm: Header V3 DSA signature: NOKEY, key ID
897da07a
error: Failed dependencies:
	curl = 7.9.5-2 is needed by curl-devel-7.9.5-2
    Suggested resolutions:
	curl-7.9.5-2.i386.rpm
bash$ rpm --version
RPM version 4.1

There's more to do of course

Note You need to log in before you can comment on or make changes to this bug.