Bug 155093 - No sound input with emu10k1 driver
No sound input with emu10k1 driver
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ALSA
  Show dependency treegraph
 
Reported: 2005-04-16 00:11 EDT by Nathan G. Grennan
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-17 11:43:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2005-04-16 00:11:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050322 Galeon/1.3.20

Description of problem:
I have tried to get input working under 2.6.11-1.1240, both line in and microphone. I have also tried 2.6.11-1.1234 and have the same problem. I tried adjusting pretty much all mixer settings. Output worked just fine. So I could play music. 2.6.11-1.1226 works just fine.

The mixer listings look very different in 2.6.11-1.1240 vs. 2.6.11-1.1226.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1240_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install 2.6.11-1.1240
2.
3.
  

Actual Results:  No sound input

Expected Results:  Sound input works

Additional info:
Comment 1 Thomas J. Baker 2005-08-30 09:55:21 EDT
I'm running 2.6.12-1.1447_FC4smp on an FC4 system and I have the same problem.
gnome-volume-control doesn't even show a capture section. System is a Dell
Precision 650 with dual 64 bit Xeons.
Comment 2 Dave Jones 2005-08-30 15:03:04 EDT
Thomas, I think you have a different problem.
The volume control applet doesn't show any inputs unless you enable them.
Go to Edit->Preferences, and enable for eg, Microphone, and a Capture tab appears.

Nathan seems to have the controls, but they don't do anything.
Comment 3 Thomas J. Baker 2005-08-30 15:22:13 EDT
I tried enabling them but no capture tab appeared. With them enabled, I get two
sliders for Mic or Aux in the playback tab. I tried running alsamixer and the
capture sliders for various inputs have no effect. It's like
gnome-volume-control can't see any input elements. Alsamixer shows them but they
don't seem to do anything.
Comment 4 Thomas J. Baker 2005-08-31 09:16:17 EDT
I actually have the exact same symptoms on my home Athlon64 system. I'm running
the SMP kernel due to you suggesting it (nx feature). So both are running x86_64
SMP kernels.
Comment 5 Thomas J. Baker 2005-09-26 14:36:49 EDT
2.6.12-1.1456_FC4smp doesn't fix this problem. I went back to the first kernel
for fc4 and it didn't work either.
Comment 6 Dave Jones 2005-09-30 03:18:01 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 7 Thomas J. Baker 2005-10-03 14:34:51 EDT
The problem still persists with 2.6.13-1.1526_FC4. I even checked on a 32bit
system and it's there too. So I have three systems with SoundBlaster Audigys and
they all don't seem to have input elements, an intel ia32e, and amd64, and an
intel ia32. All systems are running the SMP kernel, if that matters.
Comment 8 Thomas J. Baker 2005-10-05 14:26:18 EDT
This mysteriously just started working. I noticed after booting to the new
kernel the first time, my alsa settings got reset. Maybe after a second reboot
things started working better. I still don't have a capture tab on
gnome-volume-control but at least alasmixer allows sound input.
Comment 9 Dave Jones 2005-11-10 15:26:25 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 10 Thomas J. Baker 2005-11-11 16:39:25 EST
Still no capture tag on gnome-volume-control.
Comment 11 Nathan G. Grennan 2006-01-17 11:43:06 EST
I am closing this. It has been working for me for a while.

Note You need to log in before you can comment on or make changes to this bug.