Bug 1550981 - [OSP15] Creating snapshot fails when image metadata has version field
Summary: [OSP15] Creating snapshot fails when image metadata has version field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 15.0 (Stein)
Assignee: Lee Yarwood
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: 1697515 1697516 1697517
TreeView+ depends on / blocked
 
Reported: 2018-03-02 13:15 UTC by Andre
Modified: 2020-12-21 19:33 UTC (History)
13 users (show)

Fixed In Version: openstack-nova-19.0.0-0.20190403210352.0fd77f3.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1697515 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:15:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
Log from reproducer (3.96 KB, text/plain)
2018-03-02 13:15 UTC, Andre
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1717547 0 None None None 2018-03-02 13:15:36 UTC
OpenStack gerrit 614351 0 None MERGED prevent common kwargs from glance client failure 2020-05-21 14:27:19 UTC
Red Hat Knowledge Base (Solution) 3368631 0 None None None 2018-03-07 16:07:54 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:15:50 UTC

Description Andre 2018-03-02 13:15:37 UTC
Created attachment 1403022 [details]
Log from reproducer

Description of problem:

When creating a snapshot of a server using the nova API, failure occurs if the image contains the metadata property "version".
It seems like image metadata is passed as an argument to _create_v2 (nova/image/glance.py) which is then passed to call (nova/image/glance.py) as kwargs. The function already takes in context, method, and version arguments, so it seems that any of these metadata properties would cause the snapshot to fail.

How reproducible:
Always


Steps to Reproduce:
1. Create an image with metadata property "version"
2. Launch an server using this image
3. Try to create a server snapshot of the server you just launched

Actual results:
Error

Expected results:
Snapshot created

Additional info:
Bug already reported on OpenStack Launchpad https://bugs.launchpad.net/nova/+bug/1717547

Comment 15 errata-xmlrpc 2019-09-21 11:15:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.