Bug 155102 - Setting up IDE HD on S3 resume
Setting up IDE HD on S3 resume
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-16 05:52 EDT by Albert Vilella
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-18 08:27:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Vilella 2005-04-16 05:52:46 EDT
Description of problem:
The laptop won't set up IDE from a S3 suspend.
Keyboard and mouse input ok, all fine but the hda seems to have trouble
recovering (hda led blinking hard), can't execute any command because the hda is
not accessible. Kernel outputs DMA timeouts for the hdd...  After half a minute,
decides it can't set up, and goes for a controlled shutdown.

Version-Release number of selected component (if applicable):
Since ACPI exists

How reproducible:
Always

Steps to Reproduce:
1.Suspend to S3. 
2.The power LED blinks. 
If I press the power or specials button, it restores graphics, keyboard
and mouse are working but hda has problems.
3.Goes to controlled shutdown after a minute
  
Actual results:
Goes to controlled shutdown after a minute

Expected results:
Resume on S3 suspend

Additional info:
The same happens with Ubuntu Hoary:
https://bugzilla.ubuntu.com/show_bug.cgi?id=8159
This is Matthew Garrett's comment:
"Linux currently has no real support for setting up IDE interfaces on resume.
Some machines are kind enough to set the IDE interface up themselves, but on
others we're doomed to failure. I'm looking into implementing this, but it won't
happen until some time after Hoary."
Comment 1 Alan Cox 2005-04-18 08:27:58 EDT
Set to upstream

Note You need to log in before you can comment on or make changes to this bug.