Bug 1551081 - Ruby-devel should pull rpm-redhat-config
Summary: Ruby-devel should pull rpm-redhat-config
Keywords:
Status: CLOSED DUPLICATE of bug 1284684
Alias: None
Product: Fedora
Classification: Fedora
Component: ruby
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vít Ondruch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-02 17:13 UTC by Michael S.
Modified: 2018-03-02 18:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-02 18:46:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael S. 2018-03-02 17:13:46 UTC
Description of problem:

When installing ruby-devel in a very minimal env (example, a container for openshift), it seems that building a compiled gem requires gcc, and rpm-redhat-config, or it fail with a weird error.

That's kinda similar to what happened with python:
https://bugzilla.redhat.com/show_bug.cgi?id=1496757

And the fix:
https://src.fedoraproject.org/rpms/python3/pull-request/15

Would it make sense

Version-Release number of selected component (if applicable):


How reproducible:
each time

Steps to Reproduce:
1. make a docker container from F27 
2. install ruby-devel and gcc inside
3. try gem install asciibinder (for example)

Actual results:

it fail with a error related to the rpm-config

Expected results:

it shouldn't fail on that.

Additional info:

Comment 1 Vít Ondruch 2018-03-02 18:46:07 UTC

*** This bug has been marked as a duplicate of bug 1284684 ***


Note You need to log in before you can comment on or make changes to this bug.