Bug 1551179 - Automatic configuration of fencing fails on: stonith option 'action' is deprecated and should not be used
Summary: Automatic configuration of fencing fails on: stonith option 'action' is depre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michele Baldessari
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-03 00:55 UTC by Marian Krcmarik
Modified: 2019-12-29 10:29 UTC (History)
11 users (show)

Fixed In Version: python-tripleoclient-9.2.0-2.el7ost openstack-tripleo-common-8.5.1-0.20180326153322.91f52e9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:46:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1753728 None None None 2018-03-06 11:54:10 UTC
OpenStack gerrit 556210 None MERGED Remove fence_action parameter from GenerateFencingParametersAction 2020-03-31 14:22:08 UTC
OpenStack gerrit 556211 None MERGED Deprecate the action parameter for fencing generation. 2020-03-31 14:22:08 UTC
Red Hat Bugzilla 1421702 None None None 2019-07-24 15:08:23 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:48:04 UTC

Internal Links: 1421702

Description Marian Krcmarik 2018-03-03 00:55:45 UTC
Description of problem:
Automatic fencing configuration fails on:


overcloud.AllNodesDeploySteps.ControllerDeployment_Step5.2:
  resource_type: OS::Heat::StructuredDeployment
  physical_resource_id: dde00cd2-8e51-4a4d-9c79-8c9f1e5a95a9
  status: CREATE_FAILED
  status_reason: |
    Error: resources[2]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
            "                    with Stdlib::Compat::Hash. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/ssh/manifests/server.pp\", 12]:[\"/var/lib/tripleo-config/puppet_step_config.pp\", 41]", 
            "Error: pcs -f /var/lib/pacemaker/cib/puppet-cib-backup20180303-300443-1fhpyxd create failed: Error: stonith option 'action' is deprecated and should not be used, use pcmk_off_action, pcmk_reboot_action instead, use --force to override", 
            "Error: /Stage[main]/Tripleo::Fencing/Pacemaker::Stonith::Fence_ipmilan[52:54:00:c3:de:fd]/Pcmk_stonith[stonith-fence_ipmilan-525400c3defd]/ensure: change from absent to present failed: pcs -f /var/lib/pacemaker/cib/puppet-cib-backup20180303-300443-1fhpyxd create failed: Error: stonith option 'action' is deprecated and should not be used, use pcmk_off_action, pcmk_reboot_action instead, use --force to override"
        ]
    }

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run tripleo overcloud deploy with fencing template.

Actual results:
Fails due to Error: stonith option 'action' is deprecated and sho
uld not be used, use pcmk_off_action, pcmk_reboot_action instead, use --force to override"

Expected results:
Stonith devices configured

Additional info:

Comment 1 Marian Krcmarik 2018-03-05 10:29:57 UTC
Used fencing.yaml

parameter_defaults:
  EnableFencing: true
  FencingConfig:
    devices:
    - agent: fence_ipmilan
      host_mac: 52:54:00:e7:78:f9
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6231'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: ceph-2
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:8c:a0:52
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6230'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: ceph-0
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:4c:f9:59
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6234'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: ceph-1
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:e3:e1:16
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6233'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: compute-1
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:7b:d9:78
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6232'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: compute-0
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:52:d1:d0
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6237'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: controller-1
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:6d:68:1a
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6236'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: controller-0
        privlvl: administrator
    - agent: fence_ipmilan
      host_mac: 52:54:00:c3:de:fd
      params:
        action: reboot
        ipaddr: 172.16.0.1
        ipport: '6235'
        lanplus: true
        login: admin
        passwd: password
        pcmk_host_list: controller-2
        privlvl: administrator

Comment 2 Michele Baldessari 2018-03-06 08:13:27 UTC
Note that the command for overcloud fencing generation does state that you should not use this parameter:
"""
Operation to perform. Valid operations: '
on, off, reboot, status, list, diag, '
monitor or metadata. You should generally '
not use this option.'
"""

I'll see how we can fix this more cleanly though, but for now just omit it from your scripts.

Comment 6 errata-xmlrpc 2018-06-27 13:46:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.