Bug 1551465
| Summary: | Firstboot: Tries to auto-attach subscription even when the "Manually Attach subscriptions" checkbox is checked during registration | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 6 | Reporter: | Shwetha Kallesh <skallesh> |
| Component: | subscription-manager | Assignee: | Chris Snyder <csnyder> |
| Status: | CLOSED ERRATA | QA Contact: | Red Hat subscription-manager QE Team <rhsm-qe> |
| Severity: | high | Docs Contact: | |
| Priority: | high | ||
| Version: | 6.10 | CC: | bkearney, csnyder, jsefler, jstavel, mkolaja, mkorbel, rjerrido, salmy, tlestach, weiliu |
| Target Milestone: | rc | Keywords: | Regression, Triaged |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2018-06-19 05:21:43 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Attachments: | |||
[root@localhost ~]# tail -f /var/log/rhsm/rhsm.log
File "/usr/lib64/python2.6/site-packages/subscription_manager/packageprofilelib.py", line 42, in perform
ret = profile_mgr.update_check(self.uep, consumer_identity.uuid)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 418, in update_check
return CacheManager.update_check(self, uep, consumer_uuid, force)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 183, in update_check
raise Exception(_("Error updating system data on the server, see /var/log/rhsm/rhsm.log "
Exception: Error updating system data on the server, see /var/log/rhsm/rhsm.log for more details.
2018-03-05 03:56:02,515 [INFO] firstboot:3200:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=2159c3ea-78d1-4ed0-8500-03f01a5ae368, request="GET /subscription/consumers/a3a38d1a-6d9a-438b-84c3-037bafe98236/entitlements/dry-run?service_level=Premium"
2018-03-05 03:56:04,563 [INFO] firstboot:3200:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=467e7e88-fdfc-44e4-9fe5-4a224a830cac, request="GET /subscription/consumers/a3a38d1a-6d9a-438b-84c3-037bafe98236/entitlements/dry-run?service_level=Self-Support"
2018-03-05 03:56:06,304 [INFO] firstboot:3200:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=fbfb001c-e50d-4c8d-a723-84045ec59024, request="GET /subscription/consumers/a3a38d1a-6d9a-438b-84c3-037bafe98236/entitlements/dry-run?service_level=Standard"
^C
[root@localhost ~]# vi /etc/sysconfig/firstboot
[root@localhost ~]# tail -f /var/log/rhsm/rhsm.log
<NONE>
Added (new)
<NONE>
Deleted
<NONE>
2018-03-05 04:00:53,468 [ERROR] subscription-manager:3423:MainThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:00:53,511 [ERROR] rhsmd:3429:MainThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:00:53,513 [ERROR] rhsmd:3429:MainThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:03:39,842 [ERROR] firstboot:3456:MainThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:03:39,845 [ERROR] firstboot:3456:MainThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:04:28,262 [INFO] firstboot:3456:ValidateServerThread @connection.py:868 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=none
2018-03-05 04:04:29,902 [INFO] firstboot:3456:ValidateServerThread @connection.py:586 - Response: status=200, requestUuid=630836df-f0fe-4a73-9122-ee4b660d51b0, request="GET /subscription/status/"
2018-03-05 04:04:48,629 [INFO] firstboot:3456:GetOwnerListThread @connection.py:868 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=basic username=shwetha_tier1_test
2018-03-05 04:04:52,733 [INFO] firstboot:3456:GetOwnerListThread @connection.py:586 - Response: status=200, requestUuid=858a6c37-a56d-4bf9-996c-e68de97bed34, request="GET /subscription/users/shwetha_tier1_test/owners"
2018-03-05 04:04:54,074 [INFO] firstboot:3456:GetEnvironmentListThread @connection.py:586 - Response: status=200, request="GET /subscription/"
2018-03-05 04:04:54,099 [INFO] firstboot:3456:RegisterConsumerThread @dmiinfo.py:75 - Using dmidecode dump file: /dev/mem
2018-03-05 04:04:58,072 [INFO] firstboot:3456:RegisterConsumerThread @connection.py:586 - Response: status=200, requestUuid=01cee901-2a3a-4fc7-984d-963de02ad240, request="POST /subscription/consumers?owner=11343157"
2018-03-05 04:04:58,076 [ERROR] firstboot:3456:RegisterConsumerThread @identity.py:145 - Reload of consumer identity cert /etc/pki/consumer/cert.pem raised an exception with msg: [Errno 2] No such file or directory: '/etc/pki/consumer/key.pem'
2018-03-05 04:04:58,083 [INFO] firstboot:3456:RegisterConsumerThread @managerlib.py:71 - Consumer created: localhost.localdomain (57507f78-b475-4153-9d4e-0514357bb102)
2018-03-05 04:04:58,095 [INFO] firstboot:3456:RegisterConsumerThread @connection.py:868 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2018-03-05 04:04:59,810 [INFO] firstboot:3456:RegisterConsumerThread @connection.py:586 - Response: status=200, requestUuid=ce7ea1f9-e1fc-4c2b-b119-9dec23495d13, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/compliance"
2018-03-05 04:04:59,815 [INFO] firstboot:3456:RegisterConsumerThread @cert_sorter.py:205 - Product status: valid_products= partial_products= expired_products= unentitled_producs=69 future_products= valid_until=None
2018-03-05 04:05:01,158 [INFO] firstboot:3456:UpdatePackageProfileThread @connection.py:586 - Response: status=200, request="GET /subscription/"
2018-03-05 04:05:01,404 [ERROR] firstboot:3456:UpdatePackageProfileThread @cache.py:181 - Error updating system data on the server
2018-03-05 04:05:01,407 [ERROR] firstboot:3456:UpdatePackageProfileThread @cache.py:182 - decode() takes no keyword arguments
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 173, in update_check
self._sync_with_server(uep, consumer_uuid)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 430, in _sync_with_server
self.current_profile.collect())
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 149, in collect
pkg_dicts.append(pkg.to_dict())
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 53, in to_dict
'vendor': self._normalize_string(self.vendor), # bz1519512 handle vendors that aren't utf-8
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 79, in _normalize_string
return value.decode('utf-8', errors='replace')
TypeError: decode() takes no keyword arguments
2018-03-05 04:05:01,408 [ERROR] firstboot:3456:MainThread @utils.py:165 - None
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/subscription_manager/gui/registergui.py", line 2079, in _update_package_profile
retval = profile_mgr.update_check(cp, uuid)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 418, in update_check
return CacheManager.update_check(self, uep, consumer_uuid, force)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 183, in update_check
raise Exception(_("Error updating system data on the server, see /var/log/rhsm/rhsm.log "
Exception: Error updating system data on the server, see /var/log/rhsm/rhsm.log for more details.
2018-03-05 04:05:01,442 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:868 - Connection built: host=subscription.rhsm.stage.redhat.com port=443 handler=/subscription auth=identity_cert ca_dir=/etc/rhsm/ca/ insecure=False
2018-03-05 04:05:02,869 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=0bd60d21-e246-46e6-8fa8-8a0dd8646f10, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102"
2018-03-05 04:05:04,563 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=9131231c-57e4-481c-a33e-0d46f13b2491, request="GET /subscription/owners/11343157/servicelevels"
2018-03-05 04:05:06,250 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=e295fd68-d02a-421f-b532-8a0ecbda82e2, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/certificates/serials"
2018-03-05 04:05:06,250 [INFO] firstboot:3456:FindServiceLevelsThread @entcertlib.py:131 - certs updated:
Total updates: 0
Found (local) serial# []
Expected (UEP) serial# []
Added (new)
<NONE>
Deleted (rogue):
<NONE>
2018-03-05 04:05:07,889 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=a21bb920-c14c-4002-8d3c-9972c283653b, request="GET /subscription/status"
2018-03-05 04:05:09,291 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=b3383896-4d7d-4167-852d-db29b820fb51, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102"
2018-03-05 04:05:10,640 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, request="GET /subscription/"
2018-03-05 04:05:12,290 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=c2b6e4a2-0c54-42c8-8435-d118c72df476, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/content_overrides"
2018-03-05 04:05:12,594 [INFO] firstboot:3456:FindServiceLevelsThread @repolib.py:471 - repos updated: Repo updates
Total repo updates: 0
Updated
<NONE>
Added (new)
<NONE>
Deleted
<NONE>
2018-03-05 04:05:12,618 [INFO] firstboot:3456:FindServiceLevelsThread @dmiinfo.py:75 - Using dmidecode dump file: /dev/mem
2018-03-05 04:05:12,738 [ERROR] firstboot:3456:FindServiceLevelsThread @cache.py:181 - Error updating system data on the server
2018-03-05 04:05:12,738 [ERROR] firstboot:3456:FindServiceLevelsThread @cache.py:182 - decode() takes no keyword arguments
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 173, in update_check
self._sync_with_server(uep, consumer_uuid)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 430, in _sync_with_server
self.current_profile.collect())
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 149, in collect
pkg_dicts.append(pkg.to_dict())
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 53, in to_dict
'vendor': self._normalize_string(self.vendor), # bz1519512 handle vendors that aren't utf-8
File "/usr/lib64/python2.6/site-packages/rhsm/profile.py", line 79, in _normalize_string
return value.decode('utf-8', errors='replace')
TypeError: decode() takes no keyword arguments
2018-03-05 04:05:12,739 [WARNING] firstboot:3456:FindServiceLevelsThread @base_action_client.py:71 - Exception caught while running <subscription_manager.packageprofilelib.PackageProfileActionInvoker object at 0x2a43b10> update
2018-03-05 04:05:12,739 [ERROR] firstboot:3456:FindServiceLevelsThread @base_action_client.py:72 - Error updating system data on the server, see /var/log/rhsm/rhsm.log for more details.
Traceback (most recent call last):
File "/usr/lib64/python2.6/site-packages/subscription_manager/base_action_client.py", line 62, in _run_update
update_report = lib.update()
File "/usr/lib64/python2.6/site-packages/subscription_manager/certlib.py", line 32, in update
self.report = self.locker.run(self._do_update)
File "/usr/lib64/python2.6/site-packages/subscription_manager/certlib.py", line 18, in run
return action()
File "/usr/lib64/python2.6/site-packages/subscription_manager/packageprofilelib.py", line 26, in _do_update
return action.perform()
File "/usr/lib64/python2.6/site-packages/subscription_manager/packageprofilelib.py", line 42, in perform
ret = profile_mgr.update_check(self.uep, consumer_identity.uuid)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 418, in update_check
return CacheManager.update_check(self, uep, consumer_uuid, force)
File "/usr/lib64/python2.6/site-packages/subscription_manager/cache.py", line 183, in update_check
raise Exception(_("Error updating system data on the server, see /var/log/rhsm/rhsm.log "
Exception: Error updating system data on the server, see /var/log/rhsm/rhsm.log for more details.
2018-03-05 04:05:14,628 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=f6f73da7-6b59-4aa0-b3aa-5a21a1333388, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/entitlements/dry-run?service_level=Premium"
2018-03-05 04:05:16,650 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=09fd38ee-8eee-4337-9999-66a119802af7, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/entitlements/dry-run?service_level=Self-Support"
2018-03-05 04:05:18,421 [INFO] firstboot:3456:FindServiceLevelsThread @connection.py:586 - Response: status=200, requestUuid=d4b8fe0a-885a-420c-a828-c59e79c1d704, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/entitlements/dry-run?service_level=Standard"
2018-03-05 04:05:31,552 [INFO] firstboot:3456:SubscribeThread @connection.py:586 - Response: status=204, requestUuid=10c12489-fd82-41fb-9391-21311283372f, request="PUT /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102"
2018-03-05 04:05:31,553 [INFO] firstboot:3456:SubscribeThread @registergui.py:2097 - Binding to subscriptions at service level: Standard
2018-03-05 04:05:33,673 [INFO] firstboot:3456:SubscribeThread @connection.py:586 - Response: status=200, requestUuid=3f1fd4f3-91eb-4b2a-a956-d20a87a8ec52, request="POST /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/entitlements?pool=8a99f9875ea4b859015ea4c4c878012c&quantity=1"
2018-03-05 04:05:35,372 [INFO] firstboot:3456:SubscribeThread @connection.py:586 - Response: status=200, requestUuid=e10e8a0d-f7b5-4ddf-9d4a-f4116b78d55b, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/certificates/serials"
2018-03-05 04:05:37,298 [INFO] firstboot:3456:SubscribeThread @connection.py:586 - Response: status=200, requestUuid=208ba56a-9b7c-4ae8-8c0c-fefa7ff66f68, request="GET /subscription/consumers/57507f78-b475-4153-9d4e-0514357bb102/certificates?serials=1000497648716232185"
2018-03-05 04:05:37,480 [INFO] firstboot:3456:SubscribeThread @entcertlib.py:131 - certs updated:
Total updates: 1
Found (local) serial# []
Expected (UEP) serial# [1000497648716232185]
Added (new)
[sn:1000497648716232185 (Red Hat Beta,) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Enterprise Linux High Availability (for RHEL Server),) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Enterprise Linux Load Balancer (for RHEL Server),) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Oracle Java (for RHEL Server),) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Hardware Certification Test Suite,) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Enterprise Linux Server,) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Enterprise Linux Resilient Storage (for RHEL Server),) @ /etc/pki/entitlement/1000497648716232185.pem]
[sn:1000497648716232185 (Red Hat Software Collections Beta (for RHEL Server),) @ /etc/pki/entitlement/1000497648716232185.pem]
Deleted (rogue):
<NONE>
Observed the "Unable to register the system" error dialogue when tried to register the system with auto-attach option i.e even when "manually attach subscriptions after registering" option is not selecetd *** Bug 1551396 has been marked as a duplicate of this bug. *** *** Bug 1551723 has been marked as a duplicate of this bug. *** Preliminary verification: Firstboot doesnot auto-attach the subscriptions while trying to register with option "manually attach subscriptions after registering" selected with following version of rhsm Also do not see any error while registering with following version of RHSM: [root@localhost ~]# subscription-manager version server type: Red Hat Subscription Management subscription management server: 2.3.4-1 subscription management rules: 5.26 subscription-manager: 1.20.10-3.el6 Created attachment 1413105 [details]
System is registered successfully wothout any error
Created attachment 1416130 [details]
System registers successfully without any error and doesnot auto-attach subscriptions
Verified with following RHSM version
[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.3.4-1
subscription management rules: 5.26
subscription-manager: 1.20.10-3.el6
moving bug to verified as per comment 14 Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2018:1916 |
Created attachment 1404237 [details] Please see that system is trying attach subscriptions and "unable to register" error dialogue as well Description of problem: Firstboot: Tries to aut-attach subscription even when the "Manually Attach subscriptions" checkbox is checked during registration and I see the unable to register message too though system is registered successfully Version-Release number of selected component (if applicable): [root@localhost ~]# subscription-manager version server type: Red Hat Subscription Management subscription management server: 2.2.2-1 subscription management rules: 5.26 subscription-manager: 1.20.10-2.el6 How reproducible: Steps to Reproduce: 1.Firstboot -r 2.Accept the license and select the register now option ----> forward 3.Choose Service "RedHat Subscription Management" 4.Select the server you want to register with 5.Enter the valid credentials 6.Select "Manually attach subscriptions after registration" Actual results: System is registered successfully and subscriptions are auto-attached and there is an error dialogue that pops up saying "Unable to register the system" though system is registered sucessfully Expected results: System is registered successfully and subscriptions shouldnot be auto-attached No error message Additional info: