Bug 155151 - Any starting of X hangs the box on imac 333 ppc
Any starting of X hangs the box on imac 333 ppc
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
9
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Adam Jackson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-17 02:06 EDT by Clinton Goudie-Nice
Modified: 2009-07-14 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Clinton Goudie-Nice 2005-04-17 02:06:42 EDT
Description of problem:

I've got an imac 333 (revision 2.2 with the newworld rom, according to cpuinfo) 
with 320mb ram.

Any attemt to start X on this box (anaconda, rhgb, runlevel 5) hangs the box 
with a underscore cursor in the upper left.

At the time X tries to start, my ssh console into the box also becomes 
unresponsive.

results of lspci from cd install on tty 2

00:00.0 Host bridge: Morotola MPC106 [Grackle] (rev 40)
00:10.0 Class ff00: Apple Computer Inc. Paddington Mac I/O
00:12.0 VGA compatable controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 
5c)
00:14.0 USB Controller: OPTi Inc. 82C861 (rev 10)

Also after powering off the box, and back on, an inspection 
of /var/log/messages shows no specific information informaiton about why.

Here's some snippits from the xorg.conf

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     8
        SubSection "Display"
                Viewport   0 0
                Depth     8
                Modes    "1024x768"
        EndSubSection
EndSection

I've tried changing the depth setting from 8 to 32, which then changes the 
behavior of the hang to a blank screen instead of an underscore in the upper 
left. On YDL4, things dont work right with it set to 16, but it doesn't hang.

Also, here's the monitor section

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "iMac"
        DisplaySize  270        200
        HorizSync    60.0 - 60.0
        VertRefresh  75.0 - 117.0
        Option      "dpms"
EndSection

Any ideas to get X to start on this box would be appreciated, but ultimately 
getting this fixed for the release would be ideal :)


It may be worthwile to note that this box does work correctly with YDL4.0

How reproducible:
Every Time

Steps to Reproduce:

1. start X on an imac 333
2. hang
Comment 1 Clinton Goudie-Nice 2005-04-17 02:14:46 EDT
Here's some more info from the box:

----------
lspci -v -v -s 00:12.0
00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 
5c) (prog-if 00 [VGA])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping+ SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (2000ns min), Cache Line Size 08
        Interrupt: pin A routed to IRQ 22
        Region 0: Memory at 0000000081000000 (32-bit, non-prefetchable) 
[size=16M]
        Region 1: I/O ports at 0c00 [size=256]
        Region 2: Memory at 0000000080881000 (32-bit, non-prefetchable) 
[size=4K]

----------

X -scanpci --verbose
Probing for PCI devices (Bus:Device:Function)

(0:0:0) Motorola MPC106 [Grackle]
(0:16:0) Apple Computer Inc. Paddington Mac I/O
(0:18:0) ATI Technologies Inc 3D Rage Pro 215GP
(0:20:0) unknown card (0x1045/0xc861) using a OPTi Inc. 82C861
Comment 2 Clinton Goudie-Nice 2005-04-17 16:34:27 EDT
Aha I've got it. The device section is like so:

Section "Device"
        Identifier  "Videocard0"
        Driver      "fbdev"
        VendorName  "Videocard vendor"
        BoardName   "Framebuffer driver (generic)"
EndSection

It's not trying to use the ati driver.

Changing it to use the ATI driver and changing the resolution and color depth 
to 1024x768 and 24bit color and it starts
Comment 3 Adam Jackson 2006-09-29 16:51:26 EDT
We should be configuring X to do this automatically as of FC6 test3 and later. 
Please verify that this is still an issue there, and reopen if so.
Comment 4 Arnold Pena 2006-12-29 15:10:02 EST
(In reply to comment #2)
> Aha I've got it. The device section is like so:
> Section "Device"
>         Identifier  "Videocard0"
>         Driver      "fbdev"
>         VendorName  "Videocard vendor"
>         BoardName   "Framebuffer driver (generic)"
> EndSection
> It's not trying to use the ati driver.
> Changing it to use the ATI driver and changing the resolution and color depth 
> to 1024x768 and 24bit color and it starts

Clinton,

 Please help, my hd crashed, so I tried installing Fedora, but it Anaconda 
hangs at Xserver start.  Please, help me install Fedora.

Arnold (arnold_pena@sbcglobal.net)

Comment 5 Matthew Miller 2007-04-06 11:10:51 EDT
Fedora Core 3 and Fedora Core 4 are no longer supported. If you could retest
this issue on a current release or on the latest development / test version, we
would appreciate that. Otherwise, this bug will be marked as CANTFIX one month
from now. Thanks for your help and for your patience.
Comment 6 Adam Jackson 2007-05-26 15:09:32 EDT
Mass closure: This bug has been in NEEDINFO for over six weeks with no
additional information provided, and is therefore being closed.  If this bug is
still an issue for you, please supply the requested information, and reopen the bug.
Comment 7 Clinton Goudie-Nice 2008-05-15 19:16:25 EDT
Still a problem on Fedora 9
Comment 8 Clinton Goudie-Nice 2008-05-15 19:39:30 EDT
Adding the following to xorg.conf was sufficient to fix the problem

Add the following to Section "Screen"
        Monitor    "Monitor0"

Then add this chunk of monitor information to the end of the file:

Section "Monitor"
Identifier "Monitor0"
VendorName "Apple"
ModelName "iMac Rev.D 333"
HorizSync 60
VertRefresh 70-121
ModeLine "1024x768" 77.52 1024 1061 1114 1292 768 773 775 804
ModeLine "800x600" 60.60 800 820 900 1009 600 601 627 628
ModeLine "640x480" 48.12 640 640 726 802 480 481 508 510
Option "DPMS"
EndSection

Also, my initial report that it was hanging the box was erroneous. It doesn't
hang the box, but what I believe is the graphical output being out of sync makes
the imac's powerlight change from green to red.
Comment 9 Bug Zapper 2009-06-09 18:00:55 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 12:47:21 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.