Bug 1551519 - The MiqSnmp class uses the Private Enterprise Number 33482 (ManageIQ) which no longer exists, should be 2312 (Red Hat)
Summary: The MiqSnmp class uses the Private Enterprise Number 33482 (ManageIQ) which n...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.3
Assignee: Gregg Tanzillo
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks: 1561041
TreeView+ depends on / blocked
 
Reported: 2018-03-05 10:30 UTC by Peter McGowan
Modified: 2018-07-29 03:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 13:55:58 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Peter McGowan 2018-03-05 10:30:19 UTC
Description of problem:
The MiqSnmp class is hard-coded to use the Private Enterprise Number 33482 (ManageIQ) which no longer seems to be registered. This should be changed to 2312 (Red Hat Software), and a new baseoid number under this created for ManageIQ/CloudForms

Version-Release number of selected component (if applicable):
5.9

How reproducible:
Every time

Additional info:

We should also provide a MIB to make SNMP traps interpretable by a management platform. The Ovirt project has a good example of improved SNMP integration: https://bugzilla.redhat.com/show_bug.cgi?id=1136818

Comment 2 Marianne Feifer 2018-03-23 17:18:33 UTC
Hey, GT. This has a higher PM score.  Can you have someone take a look at this?


Note You need to log in before you can comment on or make changes to this bug.