Bug 1551537 - Compilation fails when including <stdlib.h>
Summary: Compilation fails when including <stdlib.h>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcc
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Susi Lehtola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-05 11:31 UTC by Horst H. von Brand
Modified: 2018-05-21 14:47 UTC (History)
1 user (show)

Fixed In Version: pcc-1.1.0-1.1.20180504cvs.fc28 pcc-1.1.0-1.1.20180504cvs.fc26 pcc-1.1.0-1.1.20180504cvs.fc27 pcc-1.1.0-1.1.20180504cvs.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 17:53:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Horst H. von Brand 2018-03-05 11:31:58 UTC
Description of problem:
Compiling any file including stdlib.h (probably others) fails:



Version-Release number of selected component (if applicable):
pcc-1.1.0-1.1.20161201cvs.fc27.3.x86_64

How reproducible:
Always

Steps to Reproduce:
1. echo '#include <stdlib.h>' > tst.c
2. pcc -c tst.c
3.

Actual results:
/usr/include/bits/floatn.h, line 61: warning: unknown mode arg __TC__
/usr/include/bits/floatn.h, line 73: invalid function definition
/usr/include/bits/floatn.h, line 73: syntax error
/usr/include/bits/floatn.h, line 73: invalid function definition
/usr/include/bits/byteswap.h, line 47: cannot recover from earlier errors: goodbye!

Expected results:
No diagnostics

Additional info:
I traced this back to pcc not having the __float128 type used in a typedef in the header. It is an alias for long double in gcc/clang. A workaround is to add:

  pcc -D__float128="long double" ...

Comment 1 Horst H. von Brand 2018-03-05 11:32:40 UTC
The same bug is in rawhide, by the way.

Comment 2 Susi Lehtola 2018-03-05 15:12:25 UTC
Ah. Actually, I just updated pcc a few days ago but looks like I'd forgotten to upload the sources which is why the packages never got built.

But, the newer snapshot doesn't work either. Mail sent to pcc-list.

Comment 3 Fedora Update System 2018-05-04 18:17:52 UTC
pcc-1.1.0-1.1.20180504cvs.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-6d2d6699f3

Comment 4 Fedora Update System 2018-05-04 18:18:00 UTC
pcc-1.1.0-1.1.20180504cvs.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-0a0c28ff3c

Comment 5 Fedora Update System 2018-05-04 18:18:05 UTC
pcc-1.1.0-1.1.20180504cvs.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4f0e1eb285

Comment 6 Fedora Update System 2018-05-04 18:18:10 UTC
pcc-1.1.0-1.1.20180504cvs.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d0e4df4642

Comment 7 Fedora Update System 2018-05-05 23:36:57 UTC
pcc-1.1.0-1.1.20180504cvs.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-6d2d6699f3

Comment 8 Fedora Update System 2018-05-06 05:34:46 UTC
pcc-1.1.0-1.1.20180504cvs.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-0a0c28ff3c

Comment 9 Fedora Update System 2018-05-06 10:08:17 UTC
pcc-1.1.0-1.1.20180504cvs.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d0e4df4642

Comment 10 Fedora Update System 2018-05-06 21:53:47 UTC
pcc-1.1.0-1.1.20180504cvs.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4f0e1eb285

Comment 11 Fedora Update System 2018-05-14 17:53:42 UTC
pcc-1.1.0-1.1.20180504cvs.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-05-14 18:01:46 UTC
pcc-1.1.0-1.1.20180504cvs.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-05-19 03:36:12 UTC
pcc-1.1.0-1.1.20180504cvs.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2018-05-21 14:47:15 UTC
pcc-1.1.0-1.1.20180504cvs.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.