Bug 1551540 - Huge slowdown in objdump -d caused by scanning the dynamic relocs
Summary: Huge slowdown in objdump -d caused by scanning the dynamic relocs
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-05 11:58 UTC by Mark Wielaard
Modified: 2018-03-13 23:18 UTC (History)
5 users (show)

Fixed In Version: binutils-2.29-13.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 23:18:12 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Wielaard 2018-03-05 11:58:11 UTC
Please backport the upstream fix for https://sourceware.org/bugzilla/show_bug.cgi?id=22911 to Fedora 27 binutils.

The slowdown of binutils -d on some binaries is huge (going from seconds to minutes). The upstream patch fixes this.

Comment 1 Nick Clifton 2018-03-05 17:59:01 UTC
Hi Mark,

  Done.  Please try binutils-2.29-13.fc27.  I am also updating F28 and rawhide.

Cheers
  Nick

Comment 2 Mark Wielaard 2018-03-07 19:48:19 UTC
(In reply to Nick Clifton from comment #1)
>   Done.  Please try binutils-2.29-13.fc27.

Thanks. I took binutils-2.29-13.fc27 from koji and objdump -d processing went from 2 minute 20 seconds to just 10 seconds (with identical output).

Note that Fedora 27 currently still contains binutils-2.29-6.fc27 since there have not been any updates since f27 was released.

Comment 3 Nick Clifton 2018-03-08 14:21:24 UTC
Hi Mark,

> Note that Fedora 27 currently still contains binutils-2.29-6.fc27 since
> there have not been any updates since f27 was released.

A good point - I have submitted a Bodhi update request.

Cheers
  Nick

Comment 4 Fedora Update System 2018-03-08 14:21:27 UTC
binutils-2.29-13.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1e994c659e

Comment 5 Fedora Update System 2018-03-08 16:24:50 UTC
binutils-2.29-13.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1e994c659e

Comment 6 Fedora Update System 2018-03-13 23:18:12 UTC
binutils-2.29-13.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.