Bug 1551872 - OpenShift package health check shouldn't fail while a higher docker version checked then requested
Summary: OpenShift package health check shouldn't fail while a higher docker version ...
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: 3.6.z
Assignee: Luke Meyer
QA Contact: Johnny Liu
Depends On: 1551862
TreeView+ depends on / blocked
Reported: 2018-03-06 03:23 UTC by Gan Huang
Modified: 2018-04-12 12:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The package_version check looks at the available version of docker that would be installed without the yum excluders. Consequence: This check fails for releases 3.6 and 3.7 (which don't support docker-1.13) if docker-1.13 is even available to install, even if the excluders would prevent it. Fix: Stop checking for docker version at all and simply rely on excluders functioning as intended. Result: No more false positives about this.
Clone Of: 1551862
Last Closed: 2018-04-12 12:50:01 UTC
Target Upstream Version:

Attachments (Terms of Use)

Description Gan Huang 2018-03-06 03:23:49 UTC
+++ This bug was initially created as a clone of Bug #1551862 +++

Description of problem:
If docker-1.13 is present on the repository, OpenShift health-check would check a higher docker version than requested and fail immediately. This is not reasonable because the higher docker version that installer checks may not what the user will use or install. 

We already have atomic-openshift-docker-excluder that prevents from installing incorrect docker version, instead the OpenShift health check should check if the supported docker version is available on current repository.

Version-Release number of the following components:

How reproducible:

Steps to Reproduce:
1. Trigger rpm installation on RHEL that have docker-1.12, docker-1.13 repo configured.

Actual results:
Failure summary:

  1. Hosts:    qe-ghuang-master-etcd-xxx.qe.rhcloud.com, qe-ghuang-node-registry-router-xx.qe.rhcloud.com
     Play:     OpenShift Health Checks
     Task:     Run health checks (install) - EL
     Message:  One or more checks failed
     Details:  check "package_version":
               Some required package(s) are available at a version
               that is higher than requested
               This will prevent installing the version you requested.
               Please check your enabled repositories or adjust openshift_release.

Expected results:
If docker-1.12 is what we're going to support in 3.7, we just need to check if docker-1.12 is available on the host regardless of docker-1.13 or others.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Luke Meyer 2018-03-09 12:14:30 UTC
The obvious workaround while 3.6 and 3.7 are waiting for this fix is to disable the check with something like this in the inventory:


The installer should install the correct version anyway. However if you are installing docker prior to running an install, ensure that you have installed docker-1.12 and not docker-1.13 for these versions.

Comment 4 Scott Dodson 2018-04-12 12:50:01 UTC
This was fixed in https://access.redhat.com/errata/RHBA-2018:1106

Note You need to log in before you can comment on or make changes to this bug.