Bug 1551904 - Network Policy shows up twice under Other Resources in different api groups
Summary: Network Policy shows up twice under Other Resources in different api groups
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-06 07:03 UTC by Yadan Pei
Modified: 2018-05-17 06:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
NetworkPolicyShowUpTwice (15.71 KB, image/png)
2018-03-06 07:08 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:17 UTC

Description Yadan Pei 2018-03-06 07:03:22 UTC
Description of problem:
Network Policy are showing twice on Other Resources, one is in extensions group and the other is in networking.k8s.io group. Should show the preferred api group instead of showing both

Version-Release number of selected component (if applicable):
v3.9.2 

How reproducible:
Always

Steps to Reproduce:
1.Login to web console and check Resource -> Other Resources page
2.
3.

Actual results:
1.Network Policy shows up twice under Other Resources

Expected results:
1. Should show the preferred api group for Network Policy instead of showing both, like Daemonsets, Daemonsets also support two api groups but only show preferred one

Additional info:

Comment 1 Yadan Pei 2018-03-06 07:08:11 UTC
Created attachment 1404638 [details]
NetworkPolicyShowUpTwice

Comment 7 Yadan Pei 2018-04-13 03:04:24 UTC
Issue fixed on v3.9.20, Network Policy show only once in Other Resources

Comment 9 Yadan Pei 2018-04-24 05:34:41 UTC
Move back to VERIFIED since mistakenly changed by scripts

Comment 12 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.