Bug 1552118 - Tasks stuck in waiting after restart of pulp services
Summary: Tasks stuck in waiting after restart of pulp services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Peter Ondrejka
URL:
Whiteboard:
: 1347410 (view as bug list)
Depends On: 1526437
Blocks: 1122832
TreeView+ depends on / blocked
 
Reported: 2018-03-06 14:24 UTC by sthirugn@redhat.com
Modified: 2019-08-12 16:14 UTC (History)
22 users (show)

Fixed In Version: pulp-2.13.4.9-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1526437
Environment:
Last Closed: 2018-04-13 13:32:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1126 None None None 2018-04-13 13:33:08 UTC
Pulp Redmine 2835 High CLOSED - CURRENTRELEASE Tasks stuck in waiting after restart of pulp services 2018-03-06 15:32:32 UTC

Comment 2 pulp-infra@redhat.com 2018-03-06 15:32:33 UTC
The Pulp upstream bug status is at CLOSED - CURRENTRELEASE. Updating the external tracker on this bug.

Comment 3 pulp-infra@redhat.com 2018-03-06 15:32:38 UTC
The Pulp upstream bug priority is at High. Updating the external tracker on this bug.

Comment 4 pulp-infra@redhat.com 2018-03-06 16:03:05 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 6 Peter Ondrejka 2018-03-28 13:02:13 UTC
Verified on satellite-6.3.1-3.el7sat.noarch, sync tasks no longer stay in waiting state if pulp services are restarted while tasks execute. In such cases, tasks are stopped with warning "Task cancelled".

Comment 8 errata-xmlrpc 2018-04-13 13:32:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1126

Comment 9 Mike McCune 2018-07-17 19:37:22 UTC
*** Bug 1347410 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.