Bug 1552214 - TripleO should configure cinder's backend_host (not host) setting for HA
Summary: TripleO should configure cinder's backend_host (not host) setting for HA
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Alan Bishop
QA Contact: Avi Avraham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-06 17:17 UTC by Alan Bishop
Modified: 2018-06-27 13:35 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180414062830.5f869f2.el7ost puppet-tripleo-8.3.2-0.20180411174307.el7ost puppet-cinder-12.4.1-0.20180329071637.4011a82.el7ost
Doc Type: Bug Fix
Doc Text:
When configuring the cinder-volume service for HA, cinder's DEFAULT/host configuration was set to "hostgroup". Other cinder services (cinder-api, cinder-scheduler, cinder-backup) would use "hostgroup" for their configuration, regardless of which overcloud node was running the service. Log messages from these services looked like they all originated from the same "hostgroup" host, which made it difficult to know which node generated the message. When deploying for HA, cinder-volume's backend_host is set to "hostgroup" instead of setting DEFAULT/host to that value. This ensures each node's DEFAULT/host value is unique. Consequently, log messages from cinder-api, cinder-scheduler, and cinder-backup are correctly associated with the node that generated the message.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:35:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1753596 None None None 2018-03-06 17:17:22 UTC
OpenStack gerrit 550110 None MERGED Fix location where backend_host is configured 2020-08-13 02:50:34 UTC
OpenStack gerrit 550111 None MERGED Update default Cinder RBD backend_host value 2020-08-13 02:50:34 UTC
OpenStack gerrit 550112 None MERGED Assign Cinder's backend_host when deploying for HA 2020-08-13 02:50:33 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:52 UTC

Description Alan Bishop 2018-03-06 17:17:22 UTC
Description of problem:

The cinder-volume service requires backend drivers uses a common value (typically "hostgroup") for the host configuration. However, this should be done using the special 'backend_host' config option, and not the 'host' option specified in the DEFAULT section of cinder.conf.

Version-Release number of selected component (if applicable):


How reproducible: Always

Steps to Reproduce:
1. Deploy cinder-volume service under pacemaker
2.
3.

Actual results:

The 'host' option in the DEFAULT section of cinder.conf is set to "hostgroup"

Expected results:

For every cinder-volume backend driver enabled, the 'backend_host' option in the backend sections of cinder.conf should be set to "hostgroup"

Additional info:

Comment 3 Alan Bishop 2018-04-23 19:21:18 UTC
Upstream patches have been merged to stable/queens.

Comment 4 Alan Bishop 2018-04-23 19:53:46 UTC
I verified the changes are already in the latest OSP-13 puddle.

Comment 9 Tzach Shefi 2018-05-17 05:50:11 UTC
Verified on:
openstack-tripleo-heat-templates-8.0.2-14.el7ost.noarch

Example of deployment with ceph backend. 

[root@controller-0 ~]# tail  /var/lib/config-data/puppet-generated/cinder/etc/cinder/cinder.conf 

[tripleo_ceph]
backend_host=hostgroup     -> looking good to verify! 
volume_backend_name=tripleo_ceph
volume_driver=cinder.volume.drivers.rbd.RBDDriver
rbd_ceph_conf=/etc/ceph/ceph.conf
rbd_user=openstack
rbd_pool=volumes

Comment 11 errata-xmlrpc 2018-06-27 13:35:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.