Bug 1552431 - This is being pulled in to satisfy lz4-devel
Summary: This is being pulled in to satisfy lz4-devel
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-mysql57
Version: rh-mysql57
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 3.1
Assignee: Michal Schorm
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1563634
TreeView+ depends on / blocked
 
Reported: 2018-03-07 06:42 UTC by digimer
Modified: 2018-05-03 06:16 UTC (History)
7 users (show)

(edit)
Clone Of:
: 1563634 (view as bug list)
(edit)
Last Closed: 2018-05-03 06:13:32 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1299 None None None 2018-05-03 06:16 UTC

Description digimer 2018-03-07 06:42:41 UTC
Description of problem:

I found today that building an RPM that has a BuildRequires of 'pkgconfig(liblz4)' fails for epel7 on x86_64 (other archs and f2{6..8} and rawhide were OK). On Sunday, the build pulled in:

- https://koji.fedoraproject.org/koji/taskinfo?taskID=25463989
====
DEBUG util.py:439:   --> lz4-devel-1.7.3-1.el7.x86_64
DEBUG util.py:439:   lz4-devel                    x86_64     1.7.3-1.el7            build      19 k
====

Today;

- https://koji.fedoraproject.org/koji/taskinfo?taskID=25533940
====
DEBUG util.py:439:   rh-mysql57-lz4-devel         x86_64     r131-5.el7             build      19 k
====

Adding a restriction to the version on the BuildRequires worked around the issue. (https://koji.fedoraproject.org/koji/taskinfo?taskID=25534496)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Build an RPM that requires lz4
2.
3.

Actual results:
Pulls in 'rh-mysql57-lz4-devel' to satisfy 'lz4-devel'.

Expected results:
Pulls in 'lz4-devel' to satisfy 'lz4-devel'.


Additional info:

Comment 2 Remi Collet 2018-03-07 07:01:08 UTC
To be clear

Actual results:
Pulls in 'rh-mysql57-lz4-devel' to satisfy 'pkgconfig(liblz4)'.

Expected results:
Pulls in 'lz4-devel' to satisfy 'pkgconfig(liblz4)'.


$ rpm -qp --provides rh-mysql57-lz4-devel-r131-5.el7.x86_64.rpm 
pkgconfig(liblz4) = 131
rh-mysql57-lz4-devel = r131-5.el7
rh-mysql57-lz4-devel(x86-64) = r131-5.el7
scl-package(rh-mysql57)

Comment 10 errata-xmlrpc 2018-05-03 06:13:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1299


Note You need to log in before you can comment on or make changes to this bug.