Bug 1552441 - DVR enable should be the default configuration for OVN deployments with L3HA
Summary: DVR enable should be the default configuration for OVN deployments with L3HA
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 13.0 (Queens)
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks: 1548947
TreeView+ depends on / blocked
 
Reported: 2018-03-07 07:21 UTC by Eran Kuris
Modified: 2019-09-09 16:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-28 15:22:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1562972 high CLOSED [Docs][Networking][QE] Deploying containerized OVN 2020-10-14 00:28:05 UTC

Internal Links: 1562972

Description Eran Kuris 2018-03-07 07:21:31 UTC
Description of problem:
Following our correspondence, 
On OVN deployment the default configuration for external connectivity access should be DVR and not L3HA as it set today.


Version-Release number of selected component (if applicable):
osp13 

How reproducible:
always
Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Eran Kuris 2018-03-07 13:28:34 UTC
To clarify the description: On OVN  DVR should be enabled by default with L3HA. 
It's effect on  SNAT use case. SNAT -  VM without floating IP access to the external network passes through Controller node.

Comment 2 Brian Haley 2018-03-12 13:44:17 UTC
This is an ongoing discussion and the details need to be flushed out, being done on the mailing list currently.  Most of the work will probably be in the TripleO component.

Comment 3 Eran Kuris 2018-03-13 09:51:25 UTC
Hi Nir,

As a PM of OVN project, can we get your inputs about this BZ?

Comment 4 Nir Yechiel 2018-04-17 10:45:24 UTC
(In reply to Eran Kuris from comment #3)
> Hi Nir,
> 
> As a PM of OVN project, can we get your inputs about this BZ?

From a user point of view I think we should default to DVR. @Daniel, @Russell, do you see any reason why we should not?

/Nir

Comment 5 Miguel Angel Ajo 2018-04-17 12:47:16 UTC
I think there's agreement on this, we need to update the deployment documents to point to that instead.

Would that be enough in your opinion?

Comment 6 Daniel Alvarez Sanchez 2018-04-17 13:08:39 UTC
It looks like we only need to update the documentation (also upstream).

Comment 7 Lucy Bopf 2018-04-23 02:38:18 UTC
Moving to 'NEW' to allow proper scoping by the documentation team.


Note You need to log in before you can comment on or make changes to this bug.