Bug 1552528 - OVN CI failure Quota exceeded for resources: ['port'].", u'type': u'OverQuota'
Summary: OVN CI failure Quota exceeded for resources: ['port'].", u'type': u'OverQuota'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutron-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Lucas Alvares Gomes
QA Contact: Arie Bregman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-07 09:37 UTC by Eran Kuris
Modified: 2019-09-09 13:55 UTC (History)
9 users (show)

Fixed In Version: python-neutron-tests-tempest-0.0.1-0.20180414005434.cca1528.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:35:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 559758 None master: MERGED neutron-tempest-plugin: Make test_create_port_when_quotas_is_full more generic (I86fe55eb48b9964b33d4b5174a248676129abfb... 2018-04-19 05:44:45 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:52 UTC

Description Eran Kuris 2018-03-07 09:37:05 UTC
Description of problem:
neutron_tempest_plugin.api.admin.test_quotas_negative.QuotasAdminNegativeTestJSON.test_create_port_when_quotas_is_full

The above tests failed with error: 
        Body: {"port": {"network_id": "2f8ba1e2-1896-4f3e-9c22-674e022b0a27", "tenant_id": "254ff034e2804c81ac2ada5811321a31"}}
    Response - Headers: {'status': '409', u'content-length': '107', 'content-location': 'http://10.0.0.108:9696/v2.0/ports', u'date': 'Mon, 05 Mar 2018 23:06:22 GMT', u'content-type': 'application/json', u'connection': 'close', u'x-openstack-request-id': 'req-6c47c038-6725-4579-a89a-104e6fb98db9'}
        Body: {"NeutronError": {"message": "Quota exceeded for resources: ['port'].", "type": "OverQuota", "detail": ""}}
2018-03-05 18:06:23,594 12145 INFO     [tempest.lib.common.rest_client] Request (QuotasAdminNegativeTestJSON:_run_cleanups): 204 DELETE http://10.0.0.108:9696/v2.0/subnets/78abe029-4ea6-4667-9eff-52aec6463b44 0.646s
2018-03-05 18:06:23,595 12145 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '204', u'content-length': '0', 'content-location': 'http://10.0.0.108:9696/v2.0/subnets/78abe029-4ea6-4667-9eff-52aec6463b44', u'date': 'Mon, 05 Mar 2018 23:06:23 GMT', u'connection': 'close', u'x-openstack-request-id': 'req-f37b04ed-8b7b-445a-a033-448f0d964172'}
        Body: 
2018-03-05 18:06:25,384 12145 INFO     [tempest.lib.common.rest_client] Request (QuotasAdminNegativeTestJSON:_run_cleanups): 204 DELETE http://10.0.0.108:9696/v2.0/networks/2f8ba1e2-1896-4f3e-9c22-674e022b0a27 1.789s
2018-03-05 18:06:25,385 12145 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '204', u'content-length': '0', 'content-location': 'http://10.0.0.108:9696/v2.0/networks/2f8ba1e2-1896-4f3e-9c22-674e022b0a27', u'date': 'Mon, 05 Mar 2018 23:06:25 GMT', u'connection': 'close', u'x-openstack-request-id': 'req-c8ce9433-aa91-487d-b1c9-0e5b07a374b7'}
        Body: 
2018-03-05 18:06:25,980 12145 INFO     [tempest.lib.common.rest_client] Request (QuotasAdminNegativeTestJSON:_run_cleanups): 204 DELETE http://10.0.0.108:9696/v2.0/quotas/254ff034e2804c81ac2ada5811321a31 0.594s
2018-03-05 18:06:25,980 12145 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: None
    Response - Headers: {'status': '204', u'content-length': '0', 'content-location': 'http://10.0.0.108:9696/v2.0/quotas/254ff034e2804c81ac2ada5811321a31', u'date': 'Mon, 05 Mar 2018 23:06:25 GMT', u'connection': 'close', u'x-openstack-request-id': 'req-0fc81db8-6e60-4f29-95e5-d4a49df93830'}
        Body:
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/admin/test_quotas_negative.py", line 83, in test_create_port_when_quotas_is_full
    port = self.admin_client.create_port(**port_args)['port']
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/services/network/json/network_client.py", line 150, in _create
    resp, body = self.post(uri, post_data)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 279, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 668, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 789, in _error_checker
    raise exceptions.Conflict(resp_body, resp=resp)
tempest.lib.exceptions.Conflict: Conflict with state of target resource
Details: {u'message': u"Quota exceeded for resources: ['port'].", u'type': u'OverQuota', u'detail': u''}

Version-Release number of selected component (if applicable):
OSP13 - puddle  2018-03-02.2 

How reproducible:
always

Steps to Reproduce:
1. run CI job 
2.
3.

Actual results:
failed

Expected results:
pass

Additional info:
logs: 
https://drive.google.com/open?id=1oFVLWVojdnunb-P-Qg3nIl4PASJyNiPr

Comment 2 Lucas Alvares Gomes 2018-04-10 13:18:23 UTC
This should be fixed upstream now at https://review.openstack.org/#/c/559758/

Comment 8 errata-xmlrpc 2018-06-27 13:35:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.