Bug 1552543 - ovn ci failure: No more IP addresses available on network d1466a9b-dc60-4ea3-842b-95228fd43b95.', u'type': u'IpAddressGenerationFailure', u'detail': u''}
Summary: ovn ci failure: No more IP addresses available on network d1466a9b-dc60-4ea3-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutron-tests-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Lucas Alvares Gomes
QA Contact: Arie Bregman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-07 10:13 UTC by Eran Kuris
Modified: 2019-09-09 15:37 UTC (History)
10 users (show)

Fixed In Version: python-neutron-tests-tempest-0.0.1-0.20180414005434.cca1528.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:35:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 559771 None MERGED Increase address allocation size for subnet pool tests with IPv4 2020-08-07 12:09:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:52 UTC

Description Eran Kuris 2018-03-07 10:13:57 UTC
Description of problem:

1.neutron_tempest_plugin.api.test_subnetpools.SubnetPoolsTest.test_create_subnet_from_pool_with_prefixlen

2.neutron_tempest_plugin.api.test_subnetpools.SubnetPoolsTest.test_create_subnet_from_pool_with_quota

3.neutron_tempest_plugin.api.test_subnetpools.SubnetPoolsTest.test_create_subnet_from_pool_with_subnet_cidr


The above tests failed with error: 
6345-4ecc-992d-d9a21834819d","name":"tempest-smoke-subnetpool-361071688"}}
2018-03-05 18:12:33,151 12140 INFO     [tempest.lib.common.rest_client] Request (SubnetPoolsTest:test_create_subnet_from_pool_with_prefixlen): 201 POST http://10.0.0.108:9696/v2.0/networks 1.957s
2018-03-05 18:12:33,151 12140 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: {"network": {"name": "tempest-test-network--1250198724"}}
    Response - Headers: {'status': '201', u'content-length': '606', 'content-location': 'http://10.0.0.108:9696/v2.0/networks', u'date': 'Mon, 05 Mar 2018 23:12:33 GMT', u'content-type': 'application/json', u'connection': 'close', u'x-openstack-request-id': 'req-cb1f0cbc-85d6-475e-be56-09050d6d059f'}
        Body: {"network":{"ipv6_address_scope":null,"dns_domain":"","revision_number":3,"port_security_enabled":true,"id":"d1466a9b-dc60-4ea3-842b-95228fd43b95","router:external":false,"availability_zone_hints":[],"availability_zones":[],"ipv4_address_scope":null,"shared":false,"project_id":"140bbf3a93544196acbb851eeb1fe5a6","status":"ACTIVE","subnets":[],"description":"","tags":[],"updated_at":"2018-03-05T23:12:31Z","is_default":false,"name":"tempest-test-network--1250198724","qos_policy_id":null,"admin_state_up":true,"tenant_id":"140bbf3a93544196acbb851eeb1fe5a6","created_at":"2018-03-05T23:12:31Z","mtu":1442}}
2018-03-05 18:12:35,229 12140 INFO     [tempest.lib.common.rest_client] Request (SubnetPoolsTest:test_create_subnet_from_pool_with_prefixlen): 409 POST http://10.0.0.108:9696/v2.0/subnets 2.077s
2018-03-05 18:12:35,229 12140 DEBUG    [tempest.lib.common.rest_client] Request - Headers: {'Content-Type': 'application/json', 'Accept': 'application/json', 'X-Auth-Token': '<omitted>'}
        Body: {"subnet": {"prefixlen": "31", "ip_version": 4, "network_id": "d1466a9b-dc60-4ea3-842b-95228fd43b95", "name": "tempest-smoke-subnetpool-475841347", "subnetpool_id": "430c8363-6345-4ecc-992d-d9a21834819d"}}
    Response - Headers: {'status': '409', u'content-length': '164', 'content-location': 'http://10.0.0.108:9696/v2.0/subnets', u'date': 'Mon, 05 Mar 2018 23:12:35 GMT', u'content-type': 'application/json', u'connection': 'close', u'x-openstack-request-id': 'req-8576630d-723a-4de5-923d-3974a69191c2'}
        Body: {"NeutronError": {"message": "No more IP addresses available on network d1466a9b-dc60-4ea3-842b-95228fd43b95.", "type": "IpAddressGenerationFailure", "detail": ""}}
}}}

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/test_subnetpools.py", line 227, in test_create_subnet_from_pool_with_prefixlen
    subnet_values=subnet_values)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/api/test_subnetpools.py", line 219, in _create_subnet_from_pool
    **subnet_kwargs)
  File "/usr/lib/python2.7/site-packages/neutron_tempest_plugin/services/network/json/network_client.py", line 150, in _create
    resp, body = self.post(uri, post_data)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 279, in post
    return self.request('POST', url, extra_headers, headers, body, chunked)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 668, in request
    self._error_checker(resp, resp_body)
  File "/usr/lib/python2.7/site-packages/tempest/lib/common/rest_client.py", line 789, in _error_checker
    raise exceptions.Conflict(resp_body, resp=resp)
tempest.lib.exceptions.Conflict: Conflict with state of target resource
Details: {u'message': u'No more IP addresses available on network d1466a9b-dc60-4ea3-842b-95228fd43b95.', u'type': u'IpAddressGenerationFailure', u'detail': u''}

Version-Release number of selected component (if applicable):
OSP13 - puddle  2018-03-02.2 

How reproducible:
always

Steps to Reproduce:
1. run CI job 
2.
3.

Actual results:
failed

Expected results:
pass

Additional info:
logs: 
https://drive.google.com/open?id=1oFVLWVojdnunb-P-Qg3nIl4PASJyNiPr

Comment 4 Lucas Alvares Gomes 2018-04-10 13:16:18 UTC
I have been looking into this failures for OVN upstream, I've now added a fix upstream for the neutron-tempest-plugin repository: https://review.openstack.org/#/c/559771/

Comment 10 errata-xmlrpc 2018-06-27 13:35:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.