Bug 155271 - Timezone difficult to select
Timezone difficult to select
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
FC5
: FutureFeature
: 160955 167913 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-04-18 14:45 EDT by Karen Pease
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 14:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karen Pease 2005-04-18 14:45:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040922

Description of problem:
Try selecting "Chicago" using either the map or dialog box.  The map is too crowded; points are right next to each other, and it's hard to tell what is what.    The dialog box abounds with entries but is only three lines tall - plus, the scroll bar's slider takes up most of the slider bar, making paging (which is only 3 lines at a time) very slow and precision in bulk moving difficult to achieve.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start an install
2. Try to select a particular city in a crowded area.  It is especially bad if you don't know that your city is supposed to be listed.
  

Additional info:
Comment 1 Ronny Buchmann 2005-04-24 10:33:15 EDT
Didn't previous versions zoom into the map (like Evolution)? No matter what it
would be very helpful this way.
Comment 2 Chris Lumens 2005-04-26 12:03:17 EDT
I agree - there are some problems with this screen.  Unfortunately, no obvious
solution to rearranging the UI is coming to me right now.  Playing with the
spacing between elements only gets you about three lines in the scrollbox which
is an improvement, but not significant.
Comment 3 Karen Pease 2005-04-26 12:56:28 EDT
Moving the map to a different tab or window (i.e., you click on a button or 
tab to choose via the map) would do it.  Both would have all of the space that 
they need. 
 
Comment 4 Jeremy Katz 2005-04-27 15:10:45 EDT
Using something like a tab introduces a different set of problems.

I have some ideas here to look at implementing for FC5.  But at this point, we
really need to be locking down to serious problems and regressions for FC4.
Comment 5 Chris Lumens 2005-06-20 10:55:03 EDT
*** Bug 160955 has been marked as a duplicate of this bug. ***
Comment 6 Dan Hollis 2005-06-20 16:41:11 EDT
the obvious solution to me is to lose the 3-line (or in some resolutions, 1.5
line) timezone listbox, replacing it with a single line "currently selected
timezone" status line.

then add a button "select timezone from a list". clicking on this button would
bring up a fullscreen text listbox of timezones you can scroll through and
select the timezone manually.
Comment 7 Dan Hollis 2005-06-20 16:44:13 EDT
or maybe make the "currently selected timezone" statusline a clickable button
itself. if you click on the map to change timezones, the button text would
change to show the currently selected timezone. but you could click on the
button to bring up a listbox you could manually select from.

clean, simple, and straightforward imo.
Comment 8 Ricky Ng-Adam 2005-11-25 20:59:07 EST
Still a problem in FC5t1
Comment 9 Jeremy Katz 2005-11-25 23:44:52 EST
Chris is working on some improvements here for test2
Comment 10 Jeremy Katz 2005-11-25 23:46:06 EST
*** Bug 167913 has been marked as a duplicate of this bug. ***
Comment 11 Need Real Name 2006-01-17 05:20:40 EST
The new selector is a lot better. Thanks :)

One question - is the selector the same in both the installer and the "Adjust
date and time> Time Zone" dialog. I seem to remember the zooming being different
in the installer..
Comment 12 Chris Lumens 2006-01-17 10:21:51 EST
Yup, the code for the widgets and zooming is the same in both places.  The
widgets themselves are layed out a bit differently in anaconda because we have
different screen requirements, but that should not affect how the zooming behaves.
Comment 13 Need Real Name 2006-01-20 15:44:34 EST
A couple of comments..

If you zoom into an area with a lot of cities, and choose what looks like your
city, but you get it wrong, you zoom out again. It would be nice if it stayed
zoomed in so that you could correct yourself.

Also, it would be good if country borders could be shown (but I know why this
isn't likely).

Note You need to log in before you can comment on or make changes to this bug.