Bug 1553235 - pdftocairo doesn't work as expected
Summary: pdftocairo doesn't work as expected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openjpeg
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Nikola Forró
QA Contact: Maryna Nalbandian
Marie Dolezelova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-08 14:52 UTC by jigar
Modified: 2018-10-30 10:13 UTC (History)
6 users (show)

Fixed In Version: openjpeg-1.5.1-18.el7
Doc Type: Release Note
Doc Text:
Decoding and conversion of JPEG 2000 images now work correctly Previously, decoding and conversion of JPEG 2000 images did not work correctly due to a bug in the `openjpeg` library. With this update, the underlying source code has been fixed, and decoding and conversion of JPEG 2000 images now works as expected.
Clone Of:
Environment:
Last Closed: 2018-10-30 10:13:22 UTC


Attachments (Terms of Use)
test file (9.68 MB, application/pdf)
2018-03-08 14:52 UTC, jigar
no flags Details
Backported patch from upstream (1.05 KB, patch)
2018-04-05 16:06 UTC, Nikola Forró
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3125 None None None 2018-10-30 10:13:26 UTC
Red Hat Knowledge Base (Solution) 3559041 None None None 2018-08-09 19:22:25 UTC

Description jigar 2018-03-08 14:52:12 UTC
Created attachment 1405882 [details]
test file

Description of problem: When trying to convert pdf to image ( jpeg ), pdftocairo fails to convert it successfully. 

Version-Release number of selected component (if applicable): poppler-0.26.5-17.el7_4

How reproducible: Always ( with given test file )

Steps to Reproduce:
1. Download the test file
2. Convert it from pdf to image format using the following command :

$ pdftocairo -jpeg -cropbox -r 360 -scale-to 2401 -x 0 -y 0 -W 2400 -H 2400 <input_file> <output_file>

3. Following errors/messages are seen while conversion in RHEL 7 :

Syntax Error: tcd_decode: incomplete bistream<0a>
Syntax Error: Error in decoding tile<0a>
Syntax Error: Failed to decode J2K image<0a>
Syntax Warning: Did no succeed opening JPX Stream as JP2, trying as J2K.
Syntax Error: 00000000: expected a marker instead of 0<0a>
Syntax Warning: Did no succeed opening JPX Stream as J2K, trying as JPT.
Syntax Error: Forbidden value encounter in message header !!<0a>
Syntax Error: [JPT-stream] : Expecting Main header first [class_Id 0] !<0a>
Syntax Error: Did no succeed opening JPX Stream.

4. Check the output file

Actual results: pdftocairo fails to convert as pdf to images successfully

Expected results: pdftocairo should convert as expected

Comment 3 Marek Kašík 2018-03-26 13:42:04 UTC
This is an issue in openjpeg package. I'm able to reproduce the same errors when running "j2k_to_image" on the extracted image.

Steps:
1) pdfimages -f 1 -l 1 -jp2 test.pdf image
2) copy the result to image.jp2, image.j2k and image.jpt
3) j2k_to_image -i image.jp2 -o image.pgm
4) j2k_to_image -i image.j2k -o image.pgm
5) j2k_to_image -i image.jpt -o image.pgm

I'm reassigning this to openjpeg.

Comment 5 Nikola Forró 2018-04-05 16:06:45 UTC
Created attachment 1417839 [details]
Backported patch from upstream

Comment 16 errata-xmlrpc 2018-10-30 10:13:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3125


Note You need to log in before you can comment on or make changes to this bug.