Bug 155342 - swig -swiglib reports wrong installation directory
swig -swiglib reports wrong installation directory
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: swig (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-19 06:33 EDT by Karsten Hopp
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-31 11:03:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-04-19 06:33:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-2 Firefox/1.0.3

Description of problem:
swig -swiglib reports /usr/lib/swig_lib on x86_64, but swig is installed in
/usr/lib64/swig_lib. During compilation of other packages (OpenIPMI) the swig
libraries aren't found

Version-Release number of selected component (if applicable):
swig-1.1p5-22

How reproducible:
Always

Steps to Reproduce:
1.try to compile a package which uses swig on a 64bit machine
2.
3.
  

Actual Results:  p.e. SWIG : Fatal error.  Unable to locate 'perl5.swg' in SWIG library.

Expected Results:  normal compilation

Additional info:
Comment 1 Karsten Hopp 2006-07-31 11:03:58 EDT
current version returns /usr/share/swig/1.3.29, this is ok on 32 and 64 bit

Note You need to log in before you can comment on or make changes to this bug.