Bug 1553422 - SELinux is preventing irqbalance from 'map' accesses on the file /etc/ld.so.cache.
Summary: SELinux is preventing irqbalance from 'map' accesses on the file /etc/ld.so.c...
Status: CLOSED DUPLICATE of bug 1513806
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:861287840202700ddbc478591f0...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-08 20:22 UTC by Subhadeep Dey
Modified: 2018-03-12 13:26 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-12 13:26:07 UTC


Attachments (Terms of Use)

Description Subhadeep Dey 2018-03-08 20:22:35 UTC
Description of problem:
SELinux is preventing irqbalance from 'map' accesses on the file /etc/ld.so.cache.

*****  Plugin restorecon (94.8 confidence) suggests   ************************

If you want to fix the label. 
/etc/ld.so.cache default label should be ld_so_cache_t.
Then you can run restorecon. The access attempt may have been stopped due to insufficient permissions to access a parent directory in which case try to change the following command accordingly.
Do
# /sbin/restorecon -v /etc/ld.so.cache

*****  Plugin catchall_labels (5.21 confidence) suggests   *******************

If you want to allow irqbalance to have map access on the ld.so.cache file
Then you need to change the label on /etc/ld.so.cache
Do
# semanage fcontext -a -t FILE_TYPE '/etc/ld.so.cache'
where FILE_TYPE is one of the following: fonts_cache_t, fonts_t, irqbalance_exec_t, ld_so_cache_t, ld_so_t, lib_t, locale_t, prelink_exec_t, textrel_shlib_t.
Then execute:
restorecon -v '/etc/ld.so.cache'


*****  Plugin catchall (1.44 confidence) suggests   **************************

If you believe that irqbalance should be allowed map access on the ld.so.cache file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'irqbalance' --raw | audit2allow -M my-irqbalance
# semodule -X 300 -i my-irqbalance.pp

Additional Information:
Source Context                system_u:system_r:irqbalance_t:s0
Target Context                system_u:object_r:etc_t:s0
Target Objects                /etc/ld.so.cache [ file ]
Source                        irqbalance
Source Path                   irqbalance
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           glibc-2.26-26.fc27.x86_64
Policy RPM                    selinux-policy-3.13.1-283.26.fc27.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.15.6-300.fc27.x86_64 #1 SMP Mon
                              Feb 26 18:43:03 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-03-09 01:48:18 IST
Last Seen                     2018-03-09 01:48:18 IST
Local ID                      5dea00b4-ba96-4c71-8d5c-1675220e0834

Raw Audit Messages
type=AVC msg=audit(1520540298.673:98): avc:  denied  { map } for  pid=694 comm="irqbalance" path="/etc/ld.so.cache" dev="dm-0" ino=273371 scontext=system_u:system_r:irqbalance_t:s0 tcontext=system_u:object_r:etc_t:s0 tclass=file permissive=0


Hash: irqbalance,irqbalance_t,etc_t,file,map

Version-Release number of selected component:
selinux-policy-3.13.1-283.26.fc27.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.15.6-300.fc27.x86_64
type:           libreport

Potential duplicate: bug 1482361

Comment 1 Lukas Vrabec 2018-03-12 13:26:07 UTC

*** This bug has been marked as a duplicate of bug 1513806 ***


Note You need to log in before you can comment on or make changes to this bug.