Bug 1553523 - [Docs][RFE][SHE] Document new default SHE deployment flow
Summary: [Docs][RFE][SHE] Document new default SHE deployment flow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.3
: ---
Assignee: Tahlia Richardson
QA Contact: Avital Pinnick
URL:
Whiteboard: docs-accepted
: 1573751 (view as bug list)
Depends On: 1455169
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-09 01:43 UTC by Tahlia Richardson
Modified: 2019-05-07 12:50 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 00:47:49 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1560462 None CLOSED [Docs][Install][SHE][Upgrade] Add Ansible repositories to documentation 2019-05-02 06:00:56 UTC

Internal Links: 1560462

Description Tahlia Richardson 2018-03-09 01:43:48 UTC
This release introduces a new alternative deployment flow for self-hosted engines. The new flow will use the current engine code to create all entities needed for successful self-hosted engine deployment.       
A local bootstrap VM with the RHV-M Appliance will be created on the host and hosted-engine-setup will use it (via Ansible) to add a host (the same one it is running on), storage domain, storage disks, and finally a VM that will later become the Manager VM in the engine (thus eliminating the need for importing it).   
Once all the entities are created, hosted-engine-setup can shut down the bootstrap VM, copy its disk to the disk it created using the engine, create the self-hosted engine configuration files, start the agent and the broker, and the Manager VM will start.

Feature page: https://github.com/oVirt/ovirt-site/pull/1273/files

From the feature page: 

All of this will be implemented using an Ansible script.
The current answer file will need to be converted to an Ansible vars file.
The configuration files will be created using Ansible templates and then packaged and copied to the correct location.

To run the script install Ansible and run:
ansible-playbook hosted-engine.yml
The script will install all the packages and will start the deployment.
For now, the vars file needs to be populated manually. Later the user's answers in the setup stage will be used to populate the values.

Comment 1 Lucy Bopf 2018-03-29 01:45:40 UTC
The RFE on which this depends is currently ON_QA. Given the fact that this is a new flow, it probably makes sense to wait until the flow is verified before beginning to document it.

Comment 4 Lucy Bopf 2018-04-16 05:10:00 UTC
Accepting into GA program and assigning to Tahlia for review.

Comment 5 Tahlia Richardson 2018-04-16 06:41:54 UTC
After further reading, bumping up the time estimate for testing and chapter restructure.

Comment 9 Sandro Bonazzola 2018-05-02 12:08:17 UTC
*** Bug 1573751 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.