Bug 1553700 - Increase max open files to 16384 to align with systemd-journald
Summary: Increase max open files to 16384 to align with systemd-journald
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog
Version: 7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiří Vymazal
QA Contact: Ondrej Moriš
Marie Dolezelova
URL:
Whiteboard:
: 1540132 (view as bug list)
Depends On: 1595781
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-09 11:00 UTC by Renaud Métrich
Modified: 2018-10-30 10:45 UTC (History)
9 users (show)

Fixed In Version: rsyslog-8.24.0-23.el7
Doc Type: Known Issue
Doc Text:
*Rsyslog* cannot proceed if the default maximum of open files is exceeded *Rsyslog* sometimes runs over the default limits for maximum number of open files. Consequently, *rsyslog* cannot open new files. To work around this problem, modify the rsyslog configuration by increasing this limit to align with systemd-journald. To do so, create a drop-in file named `/etc/systemd/system/rsyslog.service.d/increase_nofile_limit.conf` with the following content: [Service] LimitNOFILE=16384
Clone Of:
: 1564054 (view as bug list)
Environment:
Last Closed: 2018-10-30 10:17:00 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:3135 None None None 2018-10-30 10:19:08 UTC
Github rsyslog rsyslog pull 2657 None None None 2018-06-26 14:18:04 UTC
Github rsyslog rsyslog pull 2715 None None None 2018-06-26 14:18:33 UTC
Red Hat Knowledge Base (Solution) 3339431 None None None 2018-07-23 08:44:21 UTC

Description Renaud Métrich 2018-03-09 11:00:15 UTC
Description of problem:

Currently, the default max open files limit for rsyslog is:
soft: 1024
hard: 4096

These numbers are too low because rsyslog connects to the system journal and this can lead to numerous file descriptors be used (see BZ 1550575 and BZ 1540132)

systemd-journald service unit has the following property:
LimitNOFILE=16384

rsyslog service unit should have the same limit set.

Comment 13 Jiří Vymazal 2018-07-23 08:44:21 UTC
*** Bug 1540132 has been marked as a duplicate of this bug. ***

Comment 32 errata-xmlrpc 2018-10-30 10:17:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:3135


Note You need to log in before you can comment on or make changes to this bug.