Bug 1553761 - SELinux is preventing gsd-smartcard from 'map' accesses on the file /etc/pki/ca-trust/source/README.
Summary: SELinux is preventing gsd-smartcard from 'map' accesses on the file /etc/pki/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:dfc358b671c9c4d4c81171aa6ef...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-09 13:39 UTC by Lukas Ruzicka
Modified: 2018-07-29 03:21 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.14.1-36.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1624351 (view as bug list)
Environment:
Last Closed: 2018-07-29 03:21:40 UTC
Type: ---


Attachments (Terms of Use)

Description Lukas Ruzicka 2018-03-09 13:39:04 UTC
Description of problem:
This appeared after a system upgrade from a fully working Fedora 27 to Fedora 28.
SELinux is preventing gsd-smartcard from 'map' accesses on the file /etc/pki/ca-trust/source/README.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that gsd-smartcard should be allowed map access on the README file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'gsd-smartcard' --raw | audit2allow -M my-gsdsmartcard
# semodule -X 300 -i my-gsdsmartcard.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:cert_t:s0
Target Objects                /etc/pki/ca-trust/source/README [ file ]
Source                        gsd-smartcard
Source Path                   gsd-smartcard
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           ca-certificates-2018.2.22-2.fc28.noarch
Policy RPM                    selinux-policy-3.14.1-10.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.16.0-0.rc3.git0.1.fc28.x86_64 #1
                              SMP Mon Feb 26 15:15:43 UTC 2018 x86_64 x86_64
Alert Count                   6
First Seen                    2018-03-09 14:12:41 CET
Last Seen                     2018-03-09 14:12:41 CET
Local ID                      3aff0025-3e43-45a6-b8ac-79e9049d921b

Raw Audit Messages
type=AVC msg=audit(1520601161.14:249): avc:  denied  { map } for  pid=2208 comm="gsd-smartcard" path="/etc/pki/ca-trust/source/README" dev="dm-1" ino=1182089 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cert_t:s0 tclass=file permissive=0


Hash: gsd-smartcard,xdm_t,cert_t,file,map

Version-Release number of selected component:
selinux-policy-3.14.1-10.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.3
hashmarkername: setroubleshoot
kernel:         4.16.0-0.rc3.git0.1.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-03-23 13:09:25 UTC
Hi, 

Could you attach reproducer? 

Thanks,
Lukas.

Comment 2 Lukas Ruzicka 2018-06-18 10:50:10 UTC
What do you mean by a reproducer? 
I have not been able to reproduce the bug since then.

Comment 3 Fedora Update System 2018-07-25 22:27:09 UTC
selinux-policy-3.14.1-36.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1050fb248b

Comment 4 Fedora Update System 2018-07-26 16:29:41 UTC
selinux-policy-3.14.1-36.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1050fb248b

Comment 5 Fedora Update System 2018-07-29 03:21:40 UTC
selinux-policy-3.14.1-36.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.