Bug 1553766 - Deployment fails on JSON body limit
Summary: Deployment fails on JSON body limit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard: scale_lab
: 1558321 (view as bug list)
Depends On:
Blocks: 1873107
TreeView+ depends on / blocked
 
Reported: 2018-03-09 13:58 UTC by Joe Talerico
Modified: 2020-08-27 11:58 UTC (History)
7 users (show)

Fixed In Version: instack-undercloud-8.4.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1873107 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:35:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1752467 None None None 2018-03-09 16:05:50 UTC
OpenStack gerrit 548824 None MERGED Increase size of Heat max_template_size 2020-08-26 10:26:29 UTC
OpenStack gerrit 550332 None MERGED Increase size of Heat max_template_size 2020-08-26 10:26:29 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:35:57 UTC

Description Joe Talerico 2018-03-09 13:58:07 UTC
Description of problem:
Attempting to deploy in the scale lab, I get this error early on in the deployment:

WorkflowActionError: Action tripleo.parameters.update execution failed: Error validating environment for plan overcloud: ERROR: Request limit exceeded: JSON body size (2269174 bytes) exceeds maximum allowed size (2097152 bytes).
clean_up DeployOvercloud: Action tripleo.parameters.update execution failed: Error validating environment for plan overcloud: ERROR: Request limit exceeded: JSON body size (2269174 bytes) exceeds maximum allowed size (2097152 bytes).
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/osc_lib/shell.py", line 134, in run
    ret_val = super(OpenStackShell, self).run(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 279, in run
    result = self.run_subcommand(remainder)
  File "/usr/lib/python2.7/site-packages/osc_lib/shell.py", line 169, in run_subcommand
    ret_value = super(OpenStackShell, self).run_subcommand(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 400, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/command.py", line 25, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python2.7/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 950, in take_action
    self._deploy_tripleo_heat_templates_tmpdir(stack, parsed_args)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 415, in _deploy_tripleo_heat_templates_tmpdir
    new_tht_root, tht_root)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 500, in _deploy_tripleo_heat_templates
    parsed_args.plan_environment_file)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 515, in _try_overcloud_deploy_with_compat_yaml
    plan_env_file)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 274, in _heat_deploy
    stack_name, env, moved_files, tht_root)
  File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 329, in _process_and_upload_environment
    parameters=params)
  File "/usr/lib/python2.7/site-packages/tripleoclient/workflows/parameters.py", line 20, in update_parameters
    **input_)
  File "/usr/lib/python2.7/site-packages/tripleoclient/workflows/base.py", line 31, in call_action
    raise exceptions.WorkflowActionError(action, output)
WorkflowActionError: Action tripleo.parameters.update execution failed: Error validating environment for plan overcloud: ERROR: Request limit exceeded: JSON body size (2269174 bytes) exceeds maximum allowed size (2097152 bytes).


Version-Release number of selected component (if applicable):
OSP13

How reproducible:
100%

Additional info:
This seems to be a heat configuration parameter.

heat/heat.conf:max_json_body_size=2097152

For reference, OSP12 had the same value for the json body size.

Comment 1 Alex Schultz 2018-03-20 21:38:18 UTC
*** Bug 1558321 has been marked as a duplicate of this bug. ***

Comment 6 Gurenko Alex 2018-04-30 09:18:53 UTC
Verified on puddle 2018-04-26.3

[stack@undercloud-0 ~]$ grep "heat::max_json_body_size" $(!!)
grep "heat::max_json_body_size" $(locate puppet-stack-config.yaml)
heat::max_json_body_size: 4194304

(undercloud) [stack@undercloud-0 ~]$ rpm -q instack-undercloud
instack-undercloud-8.4.1-2.el7ost.noarch

Comment 9 errata-xmlrpc 2018-06-27 13:35:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.