Bug 1553792 - Gnome Software doesn't offer upgrade from F26 to F28
Summary: Gnome Software doesn't offer upgrade from F26 to F28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedPreviousReleaseBlocker
Depends On:
Blocks: F28BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-03-09 14:45 UTC by František Zatloukal
Modified: 2018-03-20 17:33 UTC (History)
6 users (show)

Fixed In Version: gnome-software-3.24.3-5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-20 17:33:11 UTC


Attachments (Terms of Use)
Gnome Software json (10.64 KB, text/plain)
2018-03-09 14:45 UTC, František Zatloukal
no flags Details

Description František Zatloukal 2018-03-09 14:45:54 UTC
Created attachment 1406280 [details]
Gnome Software json

Description of problem:
Gnome Software should offer upgrade from Fedora 26 to Fedora 28 after:
gsettings set org.gnome.software show-upgrade-prerelease true

Fedora 28 entry is in cache/gnome-software/3.24/upgrades/fedora.json (attached).

Version-Release number of selected component (if applicable):
gnome-software-3.24.3-3.fc26.x86_64
gnome-software-3.24.3-4.fc26.x86_64
(I've tested both stable and updates-testing version)

How reproducible:
Always

Steps to Reproduce:
1. gsettings set org.gnome.software show-upgrade-prerelease true
2. Launch Gnome Software

Actual results:
Gnome Software offers you upgrade to F27

Expected results:
You should see offer to upgrade from F26 to F28

Comment 1 Fedora Blocker Bugs Application 2018-03-09 14:49:15 UTC
Proposed as a Blocker for 28-beta by Fedora user frantisekz using the blocker tracking app because:

 For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed.

This criterion applies to the recommended upgrade mechanisms only.[1]

[1] https://fedoraproject.org/wiki/Upgrading#Upgrading_Fedora_Workstation

Comment 2 Geoffrey Marr 2018-03-12 20:02:18 UTC
Discussed during the 2018-03-12 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker was made as it violates the following blocker criteria for the Workstation install:

"For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from fully updated installations of the last two stable Fedora releases with that package set installed"

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-03-12/f28-blocker-review.2018-03-12-16.01.txt

Comment 3 Richard Hughes 2018-03-13 20:03:56 UTC
Fixed upstream in https://gitlab.gnome.org/GNOME/gnome-software/commit/c04bf023d6d0ba50d3c7a27403dcc3c052ed22e7

I'll do a F26 build.

Comment 4 Fedora Update System 2018-03-13 20:30:04 UTC
gnome-software-3.24.3-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3fd0a5f75f

Comment 5 František Zatloukal 2018-03-14 13:55:54 UTC
gnome-software-3.24.3-5.fc26 offers upgrade to F28.

Comment 6 Fedora Update System 2018-03-14 20:06:54 UTC
gnome-software-3.24.3-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3fd0a5f75f

Comment 7 Adam Williamson 2018-03-16 23:03:43 UTC
This should have been accepted as a previous release blocker, since it needs to be resolved in 26, not 28. (Geoff, not your fault, I should have noticed this during the meeting and put it in the #agreed). Adjusting.

Comment 8 Fedora Update System 2018-03-20 17:33:11 UTC
gnome-software-3.24.3-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.