Bug 1554263 - hexchat 2.14.0-1.fc27 has extremely slow redrawing
Summary: hexchat 2.14.0-1.fc27 has extremely slow redrawing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hexchat
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Patrick Griffis
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-12 09:28 UTC by Kamil Páral
Modified: 2018-04-01 00:41 UTC (History)
3 users (show)

Fixed In Version: hexchat-2.14.1-1.fc27 hexchat-2.14.1-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-15 15:29:10 UTC
Type: Bug


Attachments (Terms of Use)
bug demonstration video (3.54 MB, application/octet-stream)
2018-03-12 09:34 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2018-03-12 09:28:28 UTC
Description of problem:
With hexchat-2.12.4-8.fc27 everything was fine. After upgrading to hexchat-2.14.0-1.fc27, just opening the hexchat takes a full minute with 100% cpu, because opening each channel takes ~5 seconds. When resizing the window, the content takes ~5 seconds to redraw. After having resized the window, switching to a different channel takes ~3 seconds.

Hexchat is simply unusable now.

When I downgrade to older hexchat, everything works fine again.

Version-Release number of selected component (if applicable):
hexchat-2.12.4-8.fc27.x86_64
hexchat-2.14.0-1.fc27.x86_64

How reproducible:
always

Comment 1 Kamil Páral 2018-03-12 09:34:32 UTC
Created attachment 1407130 [details]
bug demonstration video

Comment 2 Kamil Páral 2018-03-12 09:38:27 UTC
This is the broken hexchat update:
https://bodhi.fedoraproject.org/updates/FEDORA-2018-2d8ce03c84

Comment 3 Patrick Griffis 2018-03-13 20:08:50 UTC
This will have been caused by https://bugzilla.redhat.com/show_bug.cgi?id=1536298

I'll CC the author

Comment 4 Fedora Update System 2018-03-14 06:11:47 UTC
hexchat-2.14.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-fc31e2f6b7

Comment 5 Fedora Update System 2018-03-14 06:12:02 UTC
hexchat-2.14.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c61b5df7d5

Comment 6 Kamil Páral 2018-03-14 10:37:00 UTC
(In reply to Fedora Update System from comment #5)
> hexchat-2.14.1-1.fc27 has been submitted as an update to Fedora 27.
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-c61b5df7d5

Thanks, this fixes my problem.

Comment 7 Fedora Update System 2018-03-14 18:05:41 UTC
hexchat-2.14.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-fc31e2f6b7

Comment 8 Fedora Update System 2018-03-14 20:44:20 UTC
hexchat-2.14.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c61b5df7d5

Comment 9 Fedora Update System 2018-03-15 15:29:10 UTC
hexchat-2.14.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-04-01 00:41:34 UTC
hexchat-2.14.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.